summaryrefslogtreecommitdiff
path: root/media-radio/xastir/xastir-2.0.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-radio/xastir/xastir-2.0.8-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-radio/xastir/xastir-2.0.8-r1.ebuild')
-rw-r--r--media-radio/xastir/xastir-2.0.8-r1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/media-radio/xastir/xastir-2.0.8-r1.ebuild b/media-radio/xastir/xastir-2.0.8-r1.ebuild
new file mode 100644
index 000000000000..dd75bd2aeb98
--- /dev/null
+++ b/media-radio/xastir/xastir-2.0.8-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="X Amateur Station Tracking and Information Reporting"
+HOMEPAGE="http://xastir.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="festival gdal geotiff graphicsmagick"
+
+DEPEND=">=x11-libs/motif-2.3:0
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-apps/xfontsel
+ dev-libs/libpcre
+ net-misc/curl
+ sys-libs/db:4.8
+ sci-libs/shapelib
+ !graphicsmagick? ( media-gfx/imagemagick:=[-hdri,-q32] )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[-q32] )
+ geotiff? ( sci-libs/proj
+ sci-libs/libgeotiff
+ media-libs/tiff:0 )
+ gdal? ( sci-libs/gdal )
+ festival? ( app-accessibility/festival )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix script location (bug #407185)
+ epatch "${FILESDIR}"/${P}-scripts.diff
+
+ # fix __FORTIFY_SOURCE warning (bug #337365)
+ epatch "${FILESDIR}"/${PN}-2.0.4-fortify.diff
+
+ # do not use builtin shapelib if sci-libs/shapelib is not installed
+ # instead build without shapelib support (bug #430704)
+ epatch "${FILESDIR}"/${P}-no-builtin-shapelib.diff
+
+ # do not filter duplicate flags (see bug 411095)
+ epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
+
+ eautoreconf
+}
+
+src_configure() {
+ # provide include path to GraphicsMagic for configure stage
+ use graphicsmagick && append-cflags -I/usr/include/GraphicsMagick
+ econf --with-pcre \
+ --with-shapelib \
+ --with-dbfawk \
+ --without-ax25 \
+ --without-gpsman \
+ $(use_with !graphicsmagick imagemagick) \
+ $(use_with graphicsmagick) \
+ $(use_with geotiff libproj) \
+ $(use_with geotiff) \
+ $(use_with gdal) \
+ $(use_with festival)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+ dodoc AUTHORS ChangeLog FAQ README README.Contributing \
+ README.Getting-Started README.MAPS
+}
+
+pkg_postinst() {
+ elog "Kernel mode AX.25 and GPSman library not supported."
+ elog
+ elog "Remember you have to be root to add addditional scripts,"
+ elog "maps and other configuration data under /usr/share/xastir."
+}