summaryrefslogtreecommitdiff
path: root/media-radio/tlf/tlf-1.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-radio/tlf/tlf-1.4.1-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-radio/tlf/tlf-1.4.1-r1.ebuild')
-rw-r--r--media-radio/tlf/tlf-1.4.1-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-radio/tlf/tlf-1.4.1-r1.ebuild b/media-radio/tlf/tlf-1.4.1-r1.ebuild
index 897ebe600935..c19feb243da0 100644
--- a/media-radio/tlf/tlf-1.4.1-r1.ebuild
+++ b/media-radio/tlf/tlf-1.4.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -20,23 +20,27 @@ RDEPEND="sys-libs/ncurses:=
dev-libs/glib:2
media-libs/hamlib:=
media-sound/sox
- dev-libs/xmlrpc-c[curl]"
+ dev-libs/xmlrpc-c[curl]
+ elibc_musl? ( sys-libs/argp-standalone )"
DEPEND="
${RDEPEND}
test? ( dev-util/cmocka )"
-PATCHES=( "${FILESDIR}"/${P}-zone_nr.patch )
+PATCHES=( "${FILESDIR}/${P}-zone_nr.patch"
+ "${FILESDIR}/${P}-musl.patch"
+ )
src_prepare() {
if has_version '>=media-libs/hamlib-4.2' ; then
sed -i -e "s/FILPATHLEN/HAMLIB_FILPATHLEN/g" "${S}"/src/sendqrg.c || die
fi
- eapply ${PATCHES}
+ eapply ${PATCHES[@]}
eapply_user
}
src_configure() {
+ use elibc_musl && append-libs argp
append-ldflags -L/usr/$(get_libdir)/hamlib
econf --enable-fldigi-xmlrpc
}