summaryrefslogtreecommitdiff
path: root/media-radio/js8call/js8call-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-radio/js8call/js8call-2.1.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-radio/js8call/js8call-2.1.0.ebuild')
-rw-r--r--media-radio/js8call/js8call-2.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-radio/js8call/js8call-2.1.0.ebuild b/media-radio/js8call/js8call-2.1.0.ebuild
new file mode 100644
index 000000000000..d886436dd36d
--- /dev/null
+++ b/media-radio/js8call/js8call-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils vcs-snapshot
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Weak signal ham radio communication"
+HOMEPAGE="https://groups.io/g/js8call"
+SRC_URI="https://bitbucket.org/widefido/js8call/get/v${PV}-ga.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtserialport:5
+ dev-qt/qtprintsupport:5
+ virtual/libusb:1
+ media-libs/portaudio
+ sci-libs/fftw:3.0[threads,fortran]
+ virtual/fortran
+ app-text/asciidoc
+ <media-libs/hamlib-3.4
+ doc? ( dev-ruby/asciidoctor )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-hamlib-type.patch" )
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/bin/rigctl{,d}-local || die
+ rm "${D}"/usr/share/doc/JS8Call -R || die
+}