summaryrefslogtreecommitdiff
path: root/media-radio/ibp/ibp-0.21-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /media-radio/ibp/ibp-0.21-r2.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'media-radio/ibp/ibp-0.21-r2.ebuild')
-rw-r--r--media-radio/ibp/ibp-0.21-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-radio/ibp/ibp-0.21-r2.ebuild b/media-radio/ibp/ibp-0.21-r2.ebuild
new file mode 100644
index 000000000000..08a4b2b5fa4a
--- /dev/null
+++ b/media-radio/ibp/ibp-0.21-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ibp.html"
+SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses:0=
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( >=x11-misc/imake-1.0.8-r1 )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ # Respect CFLAGS if built without USE=X
+ sed -i -e "s/= -D/+= -D/" Makefile || die
+
+ # Fix compile if ncurses is built with separate libtinfo
+ sed -i -e "s:-lcurses:$($(tc-getPKG_CONFIG) --libs ncurses):" Imakefile Makefile || die
+
+ eapply_user
+}
+
+src_configure() {
+ if use X ;then
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ fi
+}
+
+src_compile() {
+ if use X ; then
+ emake \
+ CC="$(tc-getCC)" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}"
+ else
+ emake CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}