summaryrefslogtreecommitdiff
path: root/media-radio/grig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /media-radio/grig
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'media-radio/grig')
-rw-r--r--media-radio/grig/Manifest3
-rw-r--r--media-radio/grig/files/grig-0.8.1-hamlib42.patch203
-rw-r--r--media-radio/grig/grig-0.8.1-r1.ebuild11
3 files changed, 216 insertions, 1 deletions
diff --git a/media-radio/grig/Manifest b/media-radio/grig/Manifest
index 4aeef6caf4f2..dbd56f4a7666 100644
--- a/media-radio/grig/Manifest
+++ b/media-radio/grig/Manifest
@@ -1,4 +1,5 @@
AUX grig-0.8.1-hamlib4.patch 3897 BLAKE2B f855040e1860d840cc993c46a0b17a341d3820f342dc1082e2a4a9ed5f1b598f50ba61215add86f6c1b59afef04194d82a80a2de1f033328e37e0edfe51f422f SHA512 b8573228232d24fe0fd750857a5b60a358279fd5e3a07dde9eff18ed3b38c09ff4bf693f63ad9f63f691d3b8937e0a7e7dff222f9aaa74d53bd064b3adf379cf
+AUX grig-0.8.1-hamlib42.patch 6661 BLAKE2B 2ba2f54d9f6d5571862ced26fdc300198c33b7430f8ea5787c02b640c80de769fcd3cecd7d44b1ec943e6a9d88d9fec322ef57c2c363d704ddefbc484bac2bc2 SHA512 c302618a824b2cb79403ca58a5506fdf0005f07ba0e0f6ef9569f0ee4043ead86589bffd9f990265253f620eddc204a4ecd9ebbf4e2cfa421d97ed7eac55e1c6
DIST grig-0.8.1.tar.gz 621728 BLAKE2B 096ac037d3e5871e32bbb80669e2bafdf061c28c420362e26aea9f01f2e399a4cb769e65aa8261b0726444d08006495de13c62ca9d9e094c44fd8cb28b36a3f1 SHA512 84eda8db5d18324f26f0775483c8272296aad05dd75f0572c01a3c7af6dbd14bff7b98cc6a61fe3c43d25193866be4b3dafdc4e68dfc37217e88b53ca53266f9
-EBUILD grig-0.8.1-r1.ebuild 708 BLAKE2B cc8849de1ba6fec66c71fc8fe9d9d0f4706b426945342946d9deef3c12a4bab5489921d3276346ff5293cd40d88a0c77dbdf5e37bfd5cac351db9b411ef9ea30 SHA512 b23d9d72836a169ab7e9be20974593095a65c70fd9d23ef48a0e641814ecd4b9080fcc872e5d219a096d38b6968dc3a676cdd09943218caa3760b4a9c996d0e8
+EBUILD grig-0.8.1-r1.ebuild 913 BLAKE2B 163eeb4716e0d5a71ee7bca0a3fbd02325226598b630b6a5a08aa707832899d8e25fa3a8141fe025e1aeff0e63d6ad5c54f5943ef954b8575ef97715e0a3f8aa SHA512 816ac3ff3765f15799eca881af3fec07a4d3f2ae6441a69d4615056e22a0ae042d50854d19b19540e540854231d656c461500a25ce3ab1ee78078e9d0b3cd4b7
MISC metadata.xml 332 BLAKE2B 79bcf349f891026edaa1a92ff783eec4e1800f8c5b86c8b500b799c5be8605f0c9fd150e623a70446b9637a78b93b12ec35b1b259dc64d672cbb2c1dcd416aca SHA512 4f7b94abe8a2e6106a68f77e32aac0156c5d138b2eda01d4cc3e1c51c3fc530c75992c0b6e901a083f98028d751876359c3e7d06465cabb5988174b5d28b4e9e
diff --git a/media-radio/grig/files/grig-0.8.1-hamlib42.patch b/media-radio/grig/files/grig-0.8.1-hamlib42.patch
new file mode 100644
index 000000000000..16c2dc851816
--- /dev/null
+++ b/media-radio/grig/files/grig-0.8.1-hamlib42.patch
@@ -0,0 +1,203 @@
+diff --git a/src/rig-daemon-check.c b/src/rig-daemon-check.c
+index 932a84c..07045bd 100644
+--- a/src/rig-daemon-check.c
++++ b/src/rig-daemon-check.c
+@@ -884,7 +884,7 @@ rig_daemon_check_level (RIG *myrig,
+ if (has_get->att || has_set->att) {
+ int i = 0;
+
+- while ((i < MAXDBLSTSIZ) && (myrig->state.attenuator[i] != 0)) {
++ while ((i < HAMLIB_MAXDBLSTSIZ) && (myrig->state.attenuator[i] != 0)) {
+ rig_data_set_att_data (i, myrig->state.attenuator[i]);
+ i++;
+ }
+@@ -895,7 +895,7 @@ rig_daemon_check_level (RIG *myrig,
+ if (has_get->preamp || has_set->preamp) {
+ int i = 0;
+
+- while ((i < MAXDBLSTSIZ) && (myrig->state.preamp[i] != 0)) {
++ while ((i < HAMLIB_MAXDBLSTSIZ) && (myrig->state.preamp[i] != 0)) {
+ rig_data_set_preamp_data (i, myrig->state.preamp[i]);
+ i++;
+ }
+diff --git a/src/rig-daemon.c b/src/rig-daemon.c
+index 0070283..c8e0ee5 100644
+--- a/src/rig-daemon.c
++++ b/src/rig-daemon.c
+@@ -537,7 +537,7 @@ rig_daemon_start (int rigid,
+ }
+
+ /* configure and open rig device */
+- strncpy (myrig->state.rigport.pathname, rigport, FILPATHLEN);
++ strncpy (myrig->state.rigport.pathname, rigport, HAMLIB_FILPATHLEN);
+ g_free (rigport);
+
+ /* set speed if any special whishes */
+diff --git a/src/rig-data.c b/src/rig-data.c
+index cc76268..1858a8d 100644
+--- a/src/rig-data.c
++++ b/src/rig-data.c
+@@ -64,10 +64,10 @@ grig_cmd_avail_t has_get; /*!< Flags to indicate reading capabilities. */
+
+
+ /** \brief List of attenuator values (absolute values). */
+-static int att[MAXDBLSTSIZ];
++static int att[HAMLIB_MAXDBLSTSIZ];
+
+ /** \brief List of preamp values. */
+-static int preamp[MAXDBLSTSIZ];
++static int preamp[HAMLIB_MAXDBLSTSIZ];
+
+ /** \brief Bit field of available VFO's */
+ static int vfo_list;
+@@ -116,7 +116,7 @@ rig_data_set_vfos (int vfos)
+ void
+ rig_data_set_att_data (int index, int data)
+ {
+- if ((index >= 0) && (index < MAXDBLSTSIZ))
++ if ((index >= 0) && (index < HAMLIB_MAXDBLSTSIZ))
+ att[index] = data;
+ }
+
+@@ -132,7 +132,7 @@ rig_data_set_att_data (int index, int data)
+ int
+ rig_data_get_att_data (int index)
+ {
+- if ((index >= 0) && (index < MAXDBLSTSIZ)) {
++ if ((index >= 0) && (index < HAMLIB_MAXDBLSTSIZ)) {
+ return att[index];
+ }
+ else {
+@@ -158,7 +158,7 @@ rig_data_get_att_index (int data)
+ return -1;
+
+ /* scan through the array */
+- while ((i < MAXDBLSTSIZ) && (att[i] != 0)) {
++ while ((i < HAMLIB_MAXDBLSTSIZ) && (att[i] != 0)) {
+ if (att[i] == data) {
+ return i;
+ }
+@@ -182,7 +182,7 @@ rig_data_get_att_index (int data)
+ void
+ rig_data_set_preamp_data (int index, int data)
+ {
+- if ((index >= 0) && (index < MAXDBLSTSIZ))
++ if ((index >= 0) && (index < HAMLIB_MAXDBLSTSIZ))
+ preamp[index] = data;
+ }
+
+@@ -198,7 +198,7 @@ rig_data_set_preamp_data (int index, int data)
+ int
+ rig_data_get_preamp_data (int index)
+ {
+- if ((index >= 0) && (index < MAXDBLSTSIZ)) {
++ if ((index >= 0) && (index < HAMLIB_MAXDBLSTSIZ)) {
+ return preamp[index];
+ }
+ else {
+@@ -225,7 +225,7 @@ rig_data_get_preamp_index (int data)
+ return -1;
+
+ /* scan through the array */
+- while ((i < MAXDBLSTSIZ) && (preamp[i] != 0)) {
++ while ((i < HAMLIB_MAXDBLSTSIZ) && (preamp[i] != 0)) {
+ if (preamp[i] == data) {
+ return i;
+ }
+diff --git a/src/rig-gui-buttons.c b/src/rig-gui-buttons.c
+index ae95f4d..6873447 100644
+--- a/src/rig-gui-buttons.c
++++ b/src/rig-gui-buttons.c
+@@ -283,10 +283,10 @@ rig_gui_buttons_create_att_selector ()
+ /* add ATT OFF ie. 0 dB */
+ gtk_combo_box_append_text (GTK_COMBO_BOX (att), _("ATT OFF"));
+
+- /* note: MAXDBLSTSIZ is defined in hamlib; it is the max size of the
++ /* note: HAMLIB_MAXDBLSTSIZ is defined in hamlib; it is the max size of the
+ ATT and preamp arrays.
+ */
+- while ((i < MAXDBLSTSIZ) && rig_data_get_att_data (i)) {
++ while ((i < HAMLIB_MAXDBLSTSIZ) && rig_data_get_att_data (i)) {
+
+ text = g_strdup_printf ("-%d dB", rig_data_get_att_data (i));
+ gtk_combo_box_append_text (GTK_COMBO_BOX (att), text);
+@@ -343,10 +343,10 @@ rig_gui_buttons_create_preamp_selector ()
+ /* add ATT OFF ie. 0 dB */
+ gtk_combo_box_append_text (GTK_COMBO_BOX (preamp), _("PREAMP OFF"));
+
+- /* note: MAXDBLSTSIZ is defined in hamlib; it is the max size of the
++ /* note: HAMLIB_MAXDBLSTSIZ is defined in hamlib; it is the max size of the
+ ATT and preamp arrays.
+ */
+- while ((i < MAXDBLSTSIZ) && rig_data_get_preamp_data (i)) {
++ while ((i < HAMLIB_MAXDBLSTSIZ) && rig_data_get_preamp_data (i)) {
+
+ text = g_strdup_printf ("%d dB", rig_data_get_preamp_data (i));
+ gtk_combo_box_append_text (GTK_COMBO_BOX (preamp), text);
+diff --git a/src/rig-gui-info.c b/src/rig-gui-info.c
+index 53733bf..d73ef2d 100644
+--- a/src/rig-gui-info.c
++++ b/src/rig-gui-info.c
+@@ -714,7 +714,7 @@ rig_gui_info_create_tunstep_frame ()
+ /* Create a table with enough rows to show the
+ max possible number of unique tuning steps.
+ */
+- table = gtk_table_new (TSLSTSIZ, 2, FALSE);
++ table = gtk_table_new (HAMLIB_TSLSTSIZ, 2, FALSE);
+
+ label = gtk_label_new (NULL);
+ gtk_label_set_markup (GTK_LABEL (label), _("<b>STEP</b>"));
+@@ -746,7 +746,7 @@ rig_gui_info_create_tunstep_frame ()
+ }
+ */
+ /* for each available tuning ste */
+- for (i = 0; i < TSLSTSIZ; i++) {
++ for (i = 0; i < HAMLIB_TSLSTSIZ; i++) {
+
+ gboolean firsthit = TRUE; /* indicates whether found mode is the first one
+ for the current tuning step. */
+@@ -757,7 +757,7 @@ rig_gui_info_create_tunstep_frame ()
+ */
+ if (myrig->caps->tuning_steps[i].ts == 0) {
+
+- i = TSLSTSIZ;
++ i = HAMLIB_TSLSTSIZ;
+ }
+
+ /* otherwise continue */
+@@ -853,7 +853,7 @@ rig_gui_info_create_frontend_frame ()
+ text = g_strdup ("");
+
+ /* loop over all available preamp values and concatenate them into a label */
+- for (i = 0; i < MAXDBLSTSIZ; i++) {
++ for (i = 0; i < HAMLIB_MAXDBLSTSIZ; i++) {
+
+ data = rig_data_get_preamp_data (i);
+
+@@ -861,7 +861,7 @@ rig_gui_info_create_frontend_frame ()
+ reached the terminator
+ */
+ if (data == 0) {
+- i = MAXDBLSTSIZ;
++ i = HAMLIB_MAXDBLSTSIZ;
+ }
+ else {
+ if (i > 0) {
+@@ -900,7 +900,7 @@ rig_gui_info_create_frontend_frame ()
+
+ text = g_strdup ("");
+ /* loop over all available attenuator values and concatenate them into a label */
+- for (i = 0; i < MAXDBLSTSIZ; i++) {
++ for (i = 0; i < HAMLIB_MAXDBLSTSIZ; i++) {
+
+ data = rig_data_get_att_data (i);
+
+@@ -908,7 +908,7 @@ rig_gui_info_create_frontend_frame ()
+ reached the terminator
+ */
+ if (data == 0) {
+- i = MAXDBLSTSIZ;
++ i = HAMLIB_MAXDBLSTSIZ;
+ }
+ else {
+ if (i > 0) {
diff --git a/media-radio/grig/grig-0.8.1-r1.ebuild b/media-radio/grig/grig-0.8.1-r1.ebuild
index 998b4e4fa866..07f9ee0da9ba 100644
--- a/media-radio/grig/grig-0.8.1-r1.ebuild
+++ b/media-radio/grig/grig-0.8.1-r1.ebuild
@@ -26,6 +26,17 @@ src_configure() {
econf --enable-hardware
}
+src_prepare() {
+ # prepare for media-radio/hamlib-4.2 change of API
+ if has_version '>=media-libs/hamlib-4.2' ; then
+ eapply -p1 "${FILESDIR}"/${P}-hamlib42.patch
+ fi
+
+ eapply ${PATCHES}
+
+ eapply_user
+}
+
src_install() {
default
make_desktop_entry ${PN} "GRig" "/usr/share/pixmaps/grig/grig-logo.png" "HamRadio"