summaryrefslogtreecommitdiff
path: root/media-radio/gpredict/gpredict-2.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 12:18:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 12:18:12 +0000
commita18f8581f716592db51c45679c46e319db13ca29 (patch)
tree74125f25c6d522f24e2577328ab2c9f83b35eac2 /media-radio/gpredict/gpredict-2.3-r2.ebuild
parentc24da107a8903eb6e86d811f19448c01fa81ba15 (diff)
gentoo auto-resync : 14:03:2023 - 12:18:11
Diffstat (limited to 'media-radio/gpredict/gpredict-2.3-r2.ebuild')
-rw-r--r--media-radio/gpredict/gpredict-2.3-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-radio/gpredict/gpredict-2.3-r2.ebuild b/media-radio/gpredict/gpredict-2.3-r2.ebuild
new file mode 100644
index 000000000000..cf8fa7dccbcf
--- /dev/null
+++ b/media-radio/gpredict/gpredict-2.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+SRC_URI="https://github.com/csete/gpredict/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/goocanvas:2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ eapply_user
+ # remove wrong doc location
+ eapply "${FILESDIR}/${P}-doc.patch"
+ eapply "${FILESDIR}/${PN}-2.2.1-fno-common.patch"
+ eapply "${FILESDIR}/${PN}-2.3-gethostbyname.patch"
+
+ eautoreconf
+}