summaryrefslogtreecommitdiff
path: root/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild')
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
new file mode 100644
index 000000000000..eaf4b75afef9
--- /dev/null
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux Fleetsync / MCD1200 decoder"
+HOMEPAGE="https://github.com/russinnes/fsync-mdc1200-decode"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+if [ "${PV}" = 9999 ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/russinnes/fsync-mdc1200-decode.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/russinnes/fsync-mdc1200-decode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE=""
+
+DEPEND="media-sound/pulseaudio:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ $(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $(pkg-config --cflags --libs libpulse-simple)
+}
+
+src_install() {
+ dobin fsync-mdc1200-decode
+}