summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild')
-rw-r--r--media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild b/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
new file mode 100644
index 000000000000..191ef0061a3e
--- /dev/null
+++ b/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: systeminfo"
+HOMEPAGE="http://firefly.vdr-developer.org/systeminfo/"
+SRC_URI="http://firefly.vdr-developer.org/systeminfo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.4.7"
+
+RDEPEND="sys-apps/lm_sensors
+ app-admin/hddtemp"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-2.3.1"; then
+ epatch "${FILESDIR}/${P}_vdr-2.3.1.patch"
+ fi
+
+ # Makefile correction, .eclass fails in some Makefiles
+ sed -e "s:(VDRINCDIR):(VDRDIR)/include:" -i Makefile
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/systeminfo/
+ insopts -m0755
+ doins "${FILESDIR}"/systeminfo.sh
+}