summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild')
-rw-r--r--media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild b/media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..8e3078d571cf
--- /dev/null
+++ b/media-plugins/vdr-satip/vdr-satip-1.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: integrates SAT>IP network devices seamlessly into VDR"
+HOMEPAGE="http://www.saunalahti.fi/~rahrenbe/vdr/satip/"
+SRC_URI="http://www.saunalahti.fi/~rahrenbe/vdr/satip/files/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2
+ >=net-misc/curl-7.36
+ || ( dev-libs/tinyxml
+ dev-libs/pugixml )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version "dev-libs/tinyxml" ; then
+ sed -e "s:#SATIP_USE_TINYXML:SATIP_USE_TINYXML:" -i Makefile
+ #BUILD_PARAMS+=" SATIP_USE_TINYXML = 1 "
+ fi
+}