summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild')
-rw-r--r--media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild b/media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild
new file mode 100644
index 000000000000..1a096aa34358
--- /dev/null
+++ b/media-plugins/vdr-rpihddevice/vdr-rpihddevice-1.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+VERSION="2193" #every bump, new version
+
+DESCRIPTION="VDR Plugin: Output Device for Raspberry Pi"
+HOMEPAGE="https://projects.vdr-developer.org/projects/plg-rpihddevice"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="~arm"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/raspberrypi-userland
+ media-video/vdr
+ virtual/ffmpeg"
+
+src_prepare() {
+ sed -i "${S}"/Makefile -e '/LDFLAGS.*VCLIBDIR/s/$/ -Wl,--no-as-needed/' || die "sed failed"
+
+ # media-libs/raspberrypi-userland to old on gentoo...
+ sed -e "s:-lbrcmGLESv2:-lGLESv2:" \
+ -e "s:-lbrcmEGL:-lEGL:" \
+ -i "${S}"/Makefile || die "sed failed"
+
+ vdr-plugin-2_src_prepare
+}