summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-graphlcd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-graphlcd/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-graphlcd/files')
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-radiotext-lcr-service.diff126
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-span.diff356
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff19
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-freetyp2.diff30
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-include.patch11
-rw-r--r--media-plugins/vdr-graphlcd/files/confd21
-rw-r--r--media-plugins/vdr-graphlcd/files/rc-addon.sh11
7 files changed, 574 insertions, 0 deletions
diff --git a/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-radiotext-lcr-service.diff b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-radiotext-lcr-service.diff
new file mode 100644
index 000000000000..8c2c180ab2c2
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-radiotext-lcr-service.diff
@@ -0,0 +1,126 @@
+diff -Naur graphlcd-0.1.4.orig/state.c graphlcd-0.1.4/state.c
+--- graphlcd-0.1.4.orig/state.c 2007-02-04 23:35:16.317687570 +0100
++++ graphlcd-0.1.4/state.c 2007-02-04 23:42:12.065780817 +0100
+@@ -16,6 +16,7 @@
+
+ #include <vdr/eitscan.h>
+ #include <vdr/i18n.h>
++#include <vdr/plugin.h>
+
+ #include "compat.h"
+
+@@ -654,6 +655,8 @@
+
+ void cGraphLCDState::GetProgramme()
+ {
++ bool ptitle = false;
++
+ mutex.Lock();
+ #if VDRVERSNUM < 10300
+ const cEventInfo * present = NULL, * following = NULL;
+@@ -670,9 +673,11 @@
+ {
+ event.presentTime = present->GetTime();
+ event.presentTitle = "";
+- if (!isempty(present->GetTitle()))
++ if (!isempty(present->GetTitle())) {
+ event.presentTitle = present->GetTitle();
+ event.presentSubtitle = "";
++ ptitle = true;
++ }
+ if (!isempty(present->GetSubtitle()))
+ event.presentSubtitle = present->GetSubtitle();
+ }
+@@ -704,9 +709,11 @@
+ {
+ event.presentTime = present->StartTime();
+ event.presentTitle = "";
+- if (!isempty(present->Title()))
++ if (!isempty(present->Title())) {
+ event.presentTitle = present->Title();
+ event.presentSubtitle = "";
++ ptitle = true;
++ }
+ if (!isempty(present->ShortText()))
+ event.presentSubtitle = present->ShortText();
+ }
+@@ -724,6 +731,54 @@
+ }
+ }
+ #endif
++
++#if VDRVERSNUM >= 10330
++ { // get&display Radiotext
++ cPlugin *p;
++ p = cPluginManager::CallFirstService("RadioTextService-v1.0", NULL);
++ if (p) {
++ RadioTextService_v1_0 rtext;
++ if (cPluginManager::CallFirstService("RadioTextService-v1.0", &rtext)) {
++ if (rtext.rds_info == 2 && strstr(rtext.rds_title, "---") == NULL) {
++ char rtpinfo[2][65], rtstr[140];
++ strcpy(rtpinfo[0], rtext.rds_title);
++ strcpy(rtpinfo[1], rtext.rds_artist);
++ sprintf(rtstr, "%02d:%02d %s | %s", rtext.title_start->tm_hour, rtext.title_start->tm_min, trim(((std::string)(rtpinfo[0]))).c_str(), trim(((std::string)(rtpinfo[1]))).c_str());
++ ptitle ? event.presentSubtitle = rtstr : event.presentTitle = rtstr;
++ }
++ else if (rtext.rds_info > 0) {
++ char rtstr[65];
++ strcpy(rtstr, rtext.rds_text);
++ ptitle ? event.presentSubtitle = trim(rtstr) : event.presentTitle = trim(rtstr);
++ }
++ }
++ }
++ }
++#endif
++
++#if VDRVERSNUM >= 10330
++ { // get&display LcrData
++ cPlugin *p;
++ p = cPluginManager::CallFirstService("LcrService-v1.0", NULL);
++ if (p)
++ {
++ LcrService_v1_0 lcrData;
++ if (cPluginManager::CallFirstService("LcrService-v1.0", &lcrData))
++ {
++ if ( strstr( lcrData.destination, "---" ) == NULL )
++ {
++ char lcrStringParts[3][25], lcrString[100];
++ strcpy( lcrStringParts[0], (const char *)lcrData.destination );
++ strcpy( lcrStringParts[1], (const char *)lcrData.price );
++ strcpy( lcrStringParts[2], (const char *)lcrData.pulse );
++ sprintf(lcrString, "%s | %s", trim((std::string)(lcrStringParts[1])).c_str(), trim((std::string)(lcrStringParts[2])).c_str());
++ event.presentTitle = trim(lcrStringParts[0]);
++ event.presentSubtitle = trim(lcrString);
++ }
++ }
++ }
++ }
++#endif
+ mutex.Unlock();
+ }
+
+diff -Naur graphlcd-0.1.4.orig/state.h graphlcd-0.1.4/state.h
+--- graphlcd-0.1.4.orig/state.h 2007-02-04 23:35:16.317687570 +0100
++++ graphlcd-0.1.4/state.h 2007-02-04 23:43:05.728759351 +0100
+@@ -130,4 +130,21 @@
+ tVolumeState GetVolumeState();
+ };
+
++// Radiotext
++struct RadioTextService_v1_0 {
++ int rds_info;
++ int rds_pty;
++ char *rds_text;
++ char *rds_title;
++ char *rds_artist;
++ struct tm *title_start;
++};
++
++// LcrData
++struct LcrService_v1_0 {
++ cString destination;
++ cString price;
++ cString pulse;
++};
++
+ #endif
diff --git a/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-span.diff b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-span.diff
new file mode 100644
index 000000000000..949049af050f
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5-span.diff
@@ -0,0 +1,356 @@
+diff -Naur graphlcd-0.1.4.orig/display.c graphlcd-0.1.4/display.c
+--- graphlcd-0.1.4.orig/display.c 2007-02-04 23:10:36.609384554 +0100
++++ graphlcd-0.1.4/display.c 2007-02-04 23:17:48.756350745 +0100
+@@ -115,6 +115,7 @@
+ nCurrentBrightness = -1;
+ LastTimeBrightness = 0;
+ bBrightnessActive = true;
++ LastTimeSA.Set(0);
+ }
+
+ cGraphLCDDisplay::~cGraphLCDDisplay()
+@@ -373,6 +374,11 @@
+ update = true;
+ }
+
++ if ( LastTimeSA.TimedOut() )
++ {
++ update = true;
++ LastTimeSA.Set(1000);
++ }
+ // update Display every second or due to an update
+ if (CurrTime != LastTime || update)
+ {
+@@ -1460,6 +1466,8 @@
+ nTopY + nProgressbarHeight,
+ GLCD::clrBlack, false);
+
++ DisplaySA();
++
+ if (1 < replay.total && 1 < replay.current) // Don't show full progressbar for endless streams
+ {
+ bitmap->DrawRectangle(FRAME_SPACE_X,
+@@ -1945,3 +1953,141 @@
+ }
+ mutex.Unlock();
+ }
++
++void cGraphLCDDisplay::DisplaySA()
++{
++// Spectrum Analyzer visualization
++ if ( GraphLCDSetup.enableSpectrumAnalyzer )
++ {
++ if (cPluginManager::CallFirstService(SPAN_GET_BAR_HEIGHTS_ID, NULL))
++ {
++ Span_GetBarHeights_v1_0 GetBarHeights;
++
++ int bandsSA = 20;
++ int falloffSA = 8;
++ int channelsSA = 1;
++
++ unsigned int bar;
++ unsigned int *barHeights = new unsigned int[bandsSA];
++ unsigned int *barHeightsLeftChannel = new unsigned int[bandsSA];
++ unsigned int *barHeightsRightChannel = new unsigned int[bandsSA];
++ unsigned int volumeLeftChannel;
++ unsigned int volumeRightChannel;
++ unsigned int volumeBothChannels;
++ unsigned int *barPeaksBothChannels = new unsigned int[bandsSA];
++ unsigned int *barPeaksLeftChannel = new unsigned int[bandsSA];
++ unsigned int *barPeaksRightChannel = new unsigned int[bandsSA];
++
++ GetBarHeights.bands = bandsSA;
++ GetBarHeights.barHeights = barHeights;
++ GetBarHeights.barHeightsLeftChannel = barHeightsLeftChannel;
++ GetBarHeights.barHeightsRightChannel = barHeightsRightChannel;
++ GetBarHeights.volumeLeftChannel = &volumeLeftChannel;
++ GetBarHeights.volumeRightChannel = &volumeRightChannel;
++ GetBarHeights.volumeBothChannels = &volumeBothChannels;
++ GetBarHeights.name = "graphlcd";
++ GetBarHeights.falloff = falloffSA;
++ GetBarHeights.barPeaksBothChannels = barPeaksBothChannels;
++ GetBarHeights.barPeaksLeftChannel = barPeaksLeftChannel;
++ GetBarHeights.barPeaksRightChannel = barPeaksRightChannel;
++
++ if ( cPluginManager::CallFirstService(SPAN_GET_BAR_HEIGHTS_ID, &GetBarHeights ))
++ {
++ int i;
++ int barWidth = 2;
++ int saStartX = FRAME_SPACE_X;
++ int saEndX = saStartX + barWidth*bandsSA*2 + bandsSA/4 - 1;
++ int saStartY = FRAME_SPACE_Y;
++ int saEndY = FRAME_SPACE_Y + bitmap->Height()/2 - 3;
++
++ LastTimeSA.Set(100);
++
++ if ( GraphLCDSetup.SAShowVolume )
++ {
++
++ saStartX = FRAME_SPACE_X + bitmap->Width()/2 - (barWidth*bandsSA*2 + bandsSA/4)/2 - 2;
++ saEndX = saStartX + barWidth*bandsSA*2 + bandsSA/4 - 1;
++
++ // left volume
++ bitmap->DrawRectangle(FRAME_SPACE_X,
++ saStartY,
++ saStartX-1,
++ saEndY + 1,
++ GLCD::clrWhite, true);
++
++ for ( i=0; (i<logo->Width()/2-2) && (i<3*(volumeLeftChannel*saStartX)/100); i++)
++ {
++ bitmap->DrawRectangle(saStartX - i - 2,
++ saStartY + saEndY/2 - i,
++ saStartX - i - 4,
++ saStartY + saEndY/2 + i,
++ GLCD::clrBlack, true);
++ }
++
++ // right volume
++ bitmap->DrawRectangle(saEndX + 1,
++ saStartY,
++ bitmap->Width() - 1,
++ saEndY + 1,
++ GLCD::clrWhite, true);
++
++ for ( i=0; (i<logo->Width()/2-2) && (i<3*(volumeRightChannel*saStartX)/100); i++)
++ {
++ bitmap->DrawRectangle(saEndX + 2 + i,
++ saStartY + saEndY/2 - i,
++ saEndX + i + 4,
++ saStartY + saEndY/2 + i,
++ GLCD::clrBlack, true);
++ }
++ }
++ // black background
++ bitmap->DrawRectangle(saStartX,
++ saStartY,
++ saEndX,
++ saEndY + 1,
++ GLCD::clrBlack, true);
++
++ for ( i=0; i < bandsSA; i++ )
++ {
++/* if ( channelsSA == 2 )
++ {
++ bar = barHeightsLeftChannel[i];
++ bar = barHeightsRightChannel[i];
++ }*/
++ if ( channelsSA == 1)
++ {
++ // the bar
++ bar = (barHeights[i]*(saEndY-saStartY))/100;
++ bitmap->DrawRectangle(saStartX + barWidth*2*(i)+ barWidth + 1,
++ saEndY,
++ saStartX + barWidth*2*(i) + barWidth+ barWidth + 1,
++ saEndY - bar,
++ GLCD::clrWhite, true);
++
++ // the peak
++ bar = (barPeaksBothChannels[i]*(saEndY-saStartY))/100;
++ if ( bar > 0 )
++ {
++ bitmap->DrawRectangle(saStartX + barWidth*2*(i)+ barWidth + 1,
++ saEndY - bar,
++ saStartX + barWidth*2*(i) + barWidth+ barWidth + 1,
++ saEndY - bar+1,
++ GLCD::clrWhite, true);
++ }
++ }
++ }
++ }
++
++ delete [] barHeights;
++ delete [] barHeightsLeftChannel;
++ delete [] barHeightsRightChannel;
++ delete [] barPeaksBothChannels;
++ delete [] barPeaksLeftChannel;
++ delete [] barPeaksRightChannel;
++ }
++ }
++}
++
++//#############################################################################################
++
++
+diff -Naur graphlcd-0.1.4.orig/display.h graphlcd-0.1.4/display.h
+--- graphlcd-0.1.4.orig/display.h 2007-02-04 23:10:36.609384554 +0100
++++ graphlcd-0.1.4/display.h 2007-02-04 23:20:24.209000170 +0100
+@@ -29,10 +29,33 @@
+ #include <vdr/thread.h>
+ #include <vdr/player.h>
+
++#define SPAN_CLIENT_CHECK_ID "Span-ClientCheck-v1.0"
++#define SPAN_GET_BAR_HEIGHTS_ID "Span-GetBarHeights-v1.0"
+
+ #define LCDMAXCARDS 4
+ static const int kMaxTabCount = 10;
+
++struct Span_Client_Check_1_0 {
++ bool *isActive;
++ bool *isRunning;
++};
++
++struct Span_GetBarHeights_v1_0 {
++ unsigned int bands; // number of bands to compute
++ unsigned int *barHeights; // the heights of the bars of the two channels combined
++ unsigned int *barHeightsLeftChannel; // the heights of the bars of the left channel
++ unsigned int *barHeightsRightChannel; // the heights of the bars of the right channel
++ unsigned int *volumeLeftChannel; // the volume of the left channels
++ unsigned int *volumeRightChannel; // the volume of the right channels
++ unsigned int *volumeBothChannels; // the combined volume of the two channels
++ const char *name; // name of the plugin that wants to get the data
++ // (must be unique for each client!)
++ unsigned int falloff; // bar falloff value
++ unsigned int *barPeaksBothChannels; // bar peaks of the two channels combined
++ unsigned int *barPeaksLeftChannel; // bar peaks of the left channel
++ unsigned int *barPeaksRightChannel; // bar peaks of the right channel
++};
++
+ enum ThreadState
+ {
+ Normal,
+@@ -104,6 +127,7 @@
+ time_t LastTime;
+ time_t LastTimeCheckSym;
+ time_t LastTimeModSym;
++ cTimeMs LastTimeSA;
+ struct timeval CurrTimeval;
+ struct timeval UpdateAt;
+
+@@ -125,6 +149,7 @@
+ void DisplayTextItem();
+ void DisplayColorButtons();
+ void DisplayVolume();
++ void DisplaySA();
+
+ void UpdateIn(long usec);
+ bool CheckAndUpdateSymbols();
+diff -Naur graphlcd-0.1.4.orig/i18n.c graphlcd-0.1.4/i18n.c
+--- graphlcd-0.1.4.orig/i18n.c 2007-02-04 23:10:38.792567843 +0100
++++ graphlcd-0.1.4/i18n.c 2007-02-04 23:23:31.966096053 +0100
+@@ -966,5 +966,53 @@
+ # endif
+ #endif
+ },
++{
++ "Show spectrum analyzer",
++ "Zeige Spectrum Analyzer",
++ "",// TODO Slovenski
++ "",// TODO Italiano
++ "",// TODO Nederlands
++ "",// TODO Portuguçês
++ "",// TODO Franais
++ "",// TODO Norsk
++ "",// TODO Suomi
++ "",// TODO Polski
++ "",// TODO Español
++ "",// TODO Ellinika
++ "",// TODO Svenska
++ "",// TODO Romnâã
++ "",// TODO Magyar
++ "",// TODO Catalàà
++#if VDRVERSNUM > 10302
++ "",// TODO Russian
++# if VDRVERSNUM > 10307
++ "",// TODO Croatian
++# endif
++#endif
++ },
++ {
++ "Show SA volume",
++ "Zeige SA Lautstrke",
++ "",// TODO Slovenski
++ "",// TODO Italiano
++ "",// TODO Nederlands
++ "",// TODO Portugus
++ "",// TODO Franêçais
++ "",// TODO Norsk
++ "",// TODO Suomi
++ "",// TODO Polski
++ "",// TODO Español
++ "",// TODO Ellinika
++ "",// TODO Svenska
++ "",// TODO Romnâã
++ "",// TODO Magyar
++ "",// TODO Catal
++#if VDRVERSNUM > 10302
++ "",// TODO Russian
++# if VDRVERSNUM > 10307
++ "",// TODO Croatian
++# endif
++#endif
++ },
+ { NULL }
+ };
+diff -Naur graphlcd-0.1.4.orig/menu.c graphlcd-0.1.4/menu.c
+--- graphlcd-0.1.4.orig/menu.c 2007-02-04 23:10:38.862563031 +0100
++++ graphlcd-0.1.4/menu.c 2007-02-04 23:24:53.710477952 +0100
+@@ -101,4 +101,6 @@
+ SetupStore("BrightnessActive", GraphLCDSetup.BrightnessActive = newGraphLCDSetup.BrightnessActive);
+ SetupStore("BrightnessIdle", GraphLCDSetup.BrightnessIdle = newGraphLCDSetup.BrightnessIdle);
+ SetupStore("BrightnessDelay", GraphLCDSetup.BrightnessDelay = newGraphLCDSetup.BrightnessDelay);
++ SetupStore("enableSpectrumAnalyzer", GraphLCDSetup.enableSpectrumAnalyzer = newGraphLCDSetup.enableSpectrumAnalyzer);
++ SetupStore("SAShowVolume", GraphLCDSetup.SAShowVolume = newGraphLCDSetup.SAShowVolume);
+ }
+diff -Naur graphlcd-0.1.4.orig/plugin.c graphlcd-0.1.4/plugin.c
+--- graphlcd-0.1.4.orig/plugin.c 2007-02-04 23:10:38.862563031 +0100
++++ graphlcd-0.1.4/plugin.c 2007-02-04 23:26:57.655292837 +0100
+@@ -54,6 +54,7 @@
+ virtual cOsdObject * MainMenuAction();
+ virtual cMenuSetupPage * SetupMenu();
+ virtual bool SetupParse(const char * Name, const char * Value);
++ virtual bool Service(const char *Id, void *Data);
+ };
+
+ cPluginGraphLCD::cPluginGraphLCD()
+@@ -243,8 +244,24 @@
+ else if (!strcasecmp(Name, "BrightnessActive")) GraphLCDSetup.BrightnessActive = atoi(Value);
+ else if (!strcasecmp(Name, "BrightnessIdle")) GraphLCDSetup.BrightnessIdle = atoi(Value);
+ else if (!strcasecmp(Name, "BrightnessDelay")) GraphLCDSetup.BrightnessDelay = atoi(Value);
++ else if (!strcasecmp(Name, "enableSpectrumAnalyzer")) GraphLCDSetup.enableSpectrumAnalyzer = atoi(Value);
++ else if (!strcasecmp(Name, "SAShowVolume")) GraphLCDSetup.SAShowVolume = atoi(Value);
+ else return false;
+ return true;
+ }
+
++bool cPluginGraphLCD::Service(const char *Id, void *Data)
++{
++ if (strcmp(Id, SPAN_CLIENT_CHECK_ID) == 0)
++ {
++ if ( GraphLCDSetup.enableSpectrumAnalyzer && (Data != NULL) )
++ {
++ *((Span_Client_Check_1_0*)Data)->isActive = true;
++ }
++ return true;
++ }
++
++ return false;
++}
++
+ VDRPLUGINCREATOR(cPluginGraphLCD); // Don't touch this!
+diff -Naur graphlcd-0.1.4.orig/setup.c graphlcd-0.1.4/setup.c
+--- graphlcd-0.1.4.orig/setup.c 2007-02-04 23:10:38.865896137 +0100
++++ graphlcd-0.1.4/setup.c 2007-02-04 23:27:59.671030635 +0100
+@@ -52,7 +52,9 @@
+ ScrollTime(500),
+ BrightnessActive(100),
+ BrightnessIdle(100),
+- BrightnessDelay(30)
++ BrightnessDelay(30),
++ enableSpectrumAnalyzer(1),
++ SAShowVolume(1)
+ {
+ }
+
+diff -Naur graphlcd-0.1.4.orig/setup.h graphlcd-0.1.4/setup.h
+--- graphlcd-0.1.4.orig/setup.h 2007-02-04 23:10:38.865896137 +0100
++++ graphlcd-0.1.4/setup.h 2007-02-04 23:28:55.347204140 +0100
+@@ -54,6 +54,8 @@
+ int BrightnessActive;
+ int BrightnessIdle;
+ int BrightnessDelay;
++ int enableSpectrumAnalyzer;
++ int SAShowVolume;
+
+ public:
+ cGraphLCDSetup(void);
diff --git a/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff
new file mode 100644
index 000000000000..fac88fb5e615
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff
@@ -0,0 +1,19 @@
+fix compile Probs up from vdr-1.5.3
+
+Joerg Bornkessel <hd_brummy@gentoo.org> 2007 06 26
+
+diff -Naur graphlcd-0.1.5.orig/layout.c graphlcd-0.1.5/layout.c
+--- graphlcd-0.1.5.orig/layout.c 2007-06-26 21:43:52.000000000 +0200
++++ graphlcd-0.1.5/layout.c 2007-06-26 21:46:05.000000000 +0200
+@@ -65,7 +65,11 @@
+ file += "/fonts/";
+ file += url.substr(4, pos - 4);
+ }
++#if APIVERSNUM >= 10503
++ return font.LoadFT2(file, cCharSetConv::SystemCharacterTable(), size);
++#else
+ return font.LoadFT2(file, I18nCharSets()[Setup.OSDLanguage], size);
++#endif
+ }
+ else
+ {
diff --git a/media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-freetyp2.diff b/media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-freetyp2.diff
new file mode 100644
index 000000000000..2c10c8697420
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-freetyp2.diff
@@ -0,0 +1,30 @@
+#bug 203856
+
+diff -Naur graphlcd-0.1.5_orig/Makefile graphlcd-0.1.5/Makefile
+--- graphlcd-0.1.5_orig/Makefile 2007-02-05 19:24:03.000000000 +0100
++++ graphlcd-0.1.5/Makefile 2007-12-31 02:08:00.000000000 +0100
+@@ -9,6 +9,9 @@
+ #
+ PLUGIN = graphlcd
+
++# define this if you built graphlcd-base with freetype:
++HAVE_FREETYPE2 = 1
++
+ ### The version number of this plugin (taken from the main source file):
+
+ VERSION = $(shell grep 'static const char \*VERSION *=' plugin.c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+@@ -51,9 +54,12 @@
+
+ INCLUDES += -I$(VDRDIR)/include -I$(DVBDIR)/include -I$(INSTALLPREFIX)/include
+
+-DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+-DEFINES += -D_GNU_SOURCE
++DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
++ifdef HAVE_FREETYPE2
++ INCLUDES += -I$(INSTALLPREFIX)/include/freetype2
++ DEFINES += -DHAVE_FREETYPE2
++endif
+
+ ### The object files (add further files here):
+
diff --git a/media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-include.patch b/media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-include.patch
new file mode 100644
index 000000000000..e96823bec88e
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.5/vdr-graphlcd-0.1.5-missing-include.patch
@@ -0,0 +1,11 @@
+diff -ru graphlcd-0.1.4-orig/display.c graphlcd-0.1.4/display.c
+--- graphlcd-0.1.4-orig/display.c 2007-02-05 11:32:23.963790615 +0100
++++ graphlcd-0.1.4/display.c 2007-02-05 11:32:35.890079873 +0100
+@@ -29,6 +29,7 @@
+
+ #include <vdr/tools.h>
+ #include <vdr/menu.h>
++#include <vdr/plugin.h>
+
+ #include "compat.h"
+
diff --git a/media-plugins/vdr-graphlcd/files/confd b/media-plugins/vdr-graphlcd/files/confd
new file mode 100644
index 000000000000..30debd446fcc
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/confd
@@ -0,0 +1,21 @@
+# /etc/conf.d/vdr.graphlcd
+
+####### Global config for Graphlcd ####################
+#
+# set fine tuning for your Display
+# in selected ${GRAPHLCD_DIR}
+#
+
+#
+# set the DIR of the graphlcd config file
+# allowed values: directory names
+# default: /etc/vdr/plugins/graphlcd/graphlcd.conf
+#GRAPHLCD_DIR=/etc/vdr/plugins/graphlcd/graphlcd.conf
+
+#
+# select driver for graphlcd display
+# allowed values: framebuffer, gu140x32f, gu256x64-372,
+# gu256x64C-3xx0, hd61830, image, ks0108,
+# sed1520, sed1330, simlcd, t6963c
+# default: t6963c
+#GRAPHLCD_DISPLAY=t6963c
diff --git a/media-plugins/vdr-graphlcd/files/rc-addon.sh b/media-plugins/vdr-graphlcd/files/rc-addon.sh
new file mode 100644
index 000000000000..305025db99fb
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/rc-addon.sh
@@ -0,0 +1,11 @@
+#
+# rc-addon-script for plugin osdteletext
+#
+
+plugin_pre_vdr_start() {
+ : ${GRAPHLCD_DIR:=/etc/vdr/plugins/graphlcd/graphlcd.conf}
+ : ${GRAPHLCD_DISPLAY:=t6963c}
+
+ add_plugin_param "-c ${GRAPHLCD_DIR}"
+ add_plugin_param "-d ${GRAPHLCD_DISPLAY}"
+}