summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-extrecmenu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-extrecmenu/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-extrecmenu/files')
-rw-r--r--media-plugins/vdr-extrecmenu/files/dvdarchive-2.3-beta-configfile.patch13
-rw-r--r--media-plugins/vdr-extrecmenu/files/dvdarchive.conf23
-rw-r--r--media-plugins/vdr-extrecmenu/files/extrecmenu.mk127
-rw-r--r--media-plugins/vdr-extrecmenu/files/vdr-extrecmenu-1.2.2_vdr-2.1.2.diff167
4 files changed, 330 insertions, 0 deletions
diff --git a/media-plugins/vdr-extrecmenu/files/dvdarchive-2.3-beta-configfile.patch b/media-plugins/vdr-extrecmenu/files/dvdarchive-2.3-beta-configfile.patch
new file mode 100644
index 000000000000..723610e8c58e
--- /dev/null
+++ b/media-plugins/vdr-extrecmenu/files/dvdarchive-2.3-beta-configfile.patch
@@ -0,0 +1,13 @@
+--- dvdarchive-2.3-beta.sh 2009-10-06 16:23:20.000000000 +0200
++++ dvdarchive-2.3-beta.sh 2009-10-06 17:32:43.000000000 +0200
+@@ -118,6 +118,10 @@
+ DEBUGLOG="/tmp/dvdarchive.sh-debug.log"
+
+ #</Configuration>
++
++# read config file
++. /etc/vdr/dvdarchive.conf
++
+ #
+ # No changes needed after this mark
+
diff --git a/media-plugins/vdr-extrecmenu/files/dvdarchive.conf b/media-plugins/vdr-extrecmenu/files/dvdarchive.conf
new file mode 100644
index 000000000000..e404f8160699
--- /dev/null
+++ b/media-plugins/vdr-extrecmenu/files/dvdarchive.conf
@@ -0,0 +1,23 @@
+# config file for /usr/bin/dvdarchive.sh
+# this is used by vdr-extrecmenu for dvdarchives
+
+# Mountpoint, the same as in fstab
+MOUNTPOINT="/mnt/cdrom" # no trailing '/'
+
+# Eject DVD for exit-codes 2 and 3 (no or wrong dvd). 1 = yes, 0 = no.
+EJECTWRONG=1
+
+# Eject DVD after unmounting. 1 = yes, 0 = no.
+EJECTUMOUNT=0
+
+# Log warnings/errors in syslog. 1 = yes, 0 = no.
+SYSLOG=1
+
+# Create a length.vdr after mounting the dvd for the played recording. 1 = yes, 0 = no.
+# Only for non-vfat and with index.vdr only on dvd.
+GETLENGTH=1
+
+# Put debug infos in file $DEBUGLOG. Only if $DEBUG=1.
+DEBUG=0
+DEBUGLOG="/tmp/dvdarchive.sh-debug.log"
+
diff --git a/media-plugins/vdr-extrecmenu/files/extrecmenu.mk b/media-plugins/vdr-extrecmenu/files/extrecmenu.mk
new file mode 100644
index 000000000000..b08519610a69
--- /dev/null
+++ b/media-plugins/vdr-extrecmenu/files/extrecmenu.mk
@@ -0,0 +1,127 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = extrecmenu
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ifdef USE_PINPLUGIN
+DEFINES += -DUSE_PINPLUGIN
+endif
+
+DEFINES += -DUSE_VDR_CUTTER
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o mymenurecordings.o mymenueditrecording.o myreplaycontrol.o mymenucommands.o mymenusetup.o tools.o
+
+### The main target:
+
+all: $(SOFILE) i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-extrecmenu/files/vdr-extrecmenu-1.2.2_vdr-2.1.2.diff b/media-plugins/vdr-extrecmenu/files/vdr-extrecmenu-1.2.2_vdr-2.1.2.diff
new file mode 100644
index 000000000000..b1f4d391a44a
--- /dev/null
+++ b/media-plugins/vdr-extrecmenu/files/vdr-extrecmenu-1.2.2_vdr-2.1.2.diff
@@ -0,0 +1,167 @@
+diff -Naur extrecmenu-1.2.2.orig/mymenueditrecording.c extrecmenu-1.2.2/mymenueditrecording.c
+--- extrecmenu-1.2.2.orig/mymenueditrecording.c 2013-10-23 13:14:38.010071212 +0200
++++ extrecmenu-1.2.2/mymenueditrecording.c 2013-10-23 13:21:12.560096164 +0200
+@@ -76,7 +76,11 @@
+
+ if(isdir)
+ {
++#if APIVERSNUM > 20101
++ if(-1==asprintf(&oldname,"%s%s%s/%s",cVideoDirectory::Name(),tmppath?"/":"",dirbase?dirbase:"",dirname))
++#else
+ if(-1==asprintf(&oldname,"%s%s%s/%s",VideoDirectory,tmppath?"/":"",dirbase?dirbase:"",dirname))
++#endif
+ oldname=NULL;
+ }
+ else
+@@ -84,7 +88,11 @@
+
+ if(oldname)
+ {
++#if APIVERSNUM > 20101
++ if(-1==asprintf(&newname,"%s%s%s/%s%s",cVideoDirectory::Name(),tmppath?"/":"",tmppath?tmppath:"",tmpname,isdir?"":strrchr(recording->FileName(),'/')))
++#else
+ if(-1==asprintf(&newname,"%s%s%s/%s%s",VideoDirectory,tmppath?"/":"",tmppath?tmppath:"",tmpname,isdir?"":strrchr(recording->FileName(),'/')))
++#endif
+ newname=NULL;
+
+ if(newname)
+@@ -305,7 +313,11 @@
+
+ if(dirname)
+ {
++#if APIVERSNUM > 20101
++ if(-1==asprintf(&oldname,"%s%s%s/%s",cVideoDirectory::Name(),dirbase?"/":"",tmpdirbase?tmpdirbase:"",tmpdirname))
++#else
+ if(-1==asprintf(&oldname,"%s%s%s/%s",VideoDirectory,dirbase?"/":"",tmpdirbase?tmpdirbase:"",tmpdirname))
++#endif
+ oldname=NULL;
+ }
+ else
+@@ -357,7 +369,11 @@
+ if(dir)
+ dir=ExchangeChars(dir,true);
+
++#if APIVERSNUM > 20101
++ if(-1==asprintf(&_newname,"%s%s%s%s",cVideoDirectory::Name(),dir?"/":"",dir?dir:"",strrchr(dirname?oldname:recording->FileName(),'/')))
++#else
+ if(-1==asprintf(&_newname,"%s%s%s%s",VideoDirectory,dir?"/":"",dir?dir:"",strrchr(dirname?oldname:recording->FileName(),'/')))
++#endif
+ _newname=NULL;
+
+ if(_newname)
+@@ -424,7 +440,11 @@
+ {
+ if(!strncmp(oldname,rec->FileName(),strlen(oldname)))
+ {
++#if APIVERSNUM > 20101
++ char *_buf=ExchangeChars(strdup(oldname+strlen(cVideoDirectory::Name())+1),false);
++#else
+ char *_buf=ExchangeChars(strdup(oldname+strlen(VideoDirectory)+1),false);
++#endif
+
+ if(strcmp(rec->Name(),_buf))
+ {
+diff -Naur extrecmenu-1.2.2.orig/mymenurecordings.c extrecmenu-1.2.2/mymenurecordings.c
+--- extrecmenu-1.2.2.orig/mymenurecordings.c 2013-10-23 13:14:38.010071212 +0200
++++ extrecmenu-1.2.2/mymenurecordings.c 2013-10-23 13:27:17.916785937 +0200
+@@ -590,7 +590,11 @@
+ {
+ if(mysetup.FileSystemFreeMB)
+ {
++#if APIVERSNUM > 20101
++ string path=cVideoDirectory::Name();
++#else
+ string path=VideoDirectory;
++#endif
+ path+="/";
+ char *tmpbase=base?ExchangeChars(strdup(base),true):NULL;
+ if(base)
+@@ -634,7 +638,11 @@
+ else
+ {
+ int freemb;
++#if APIVERSNUM > 20101
++ cVideoDirectory::VideoDiskSpace(&freemb);
++#else
+ VideoDiskSpace(&freemb);
++#endif
+ return freemb;
+ }
+
+@@ -747,7 +755,11 @@
+ for(cRecording *recording=Recordings.First();recording;recording=Recordings.Next(recording))
+ list->Add(new myRecListItem(recording));
+ // sort my recordings list
++#if APIVERSNUM > 20101
++ string path=cVideoDirectory::Name();
++#else
+ string path=VideoDirectory;
++#endif
+ path+="/";
+ if(base)
+ path+=base;
+@@ -1211,7 +1223,11 @@
+ {
+ char *strBase=base?ExchangeChars(strdup(base), true):NULL;
+ char *strName=ExchangeChars(strdup(item->Name()), true);
++#if APIVERSNUM > 20101
++ if(-1==asprintf(&parameter,"\"%s/%s/%s\"",cVideoDirectory::Name(),strBase?strBase:"", strName))
++#else
+ if(-1==asprintf(&parameter,"\"%s/%s/%s\"",VideoDirectory,strBase?strBase:"", strName))
++#endif
+ parameter=NULL;
+ free(strBase);
+ free(strName);
+@@ -1235,7 +1251,11 @@
+ // change sorting
+ eOSState myMenuRecordings::ChangeSorting()
+ {
++#if APIVERSNUM > 20101
++ string path=cVideoDirectory::Name();
++#else
+ string path=VideoDirectory;
++#endif
+ path+="/";
+ if(base)
+ path+=base;
+diff -Naur extrecmenu-1.2.2.orig/tools.c extrecmenu-1.2.2/tools.c
+--- extrecmenu-1.2.2.orig/tools.c 2013-10-23 13:14:38.010071212 +0200
++++ extrecmenu-1.2.2/tools.c 2013-10-23 13:36:56.026822499 +0200
+@@ -152,7 +152,11 @@
+ {
+ if(!strncmp(OldName,item->recording->FileName(),strlen(OldName)))
+ {
++#if APIVERSNUM > 20101
++ buf=strdup(OldName+strlen(cVideoDirectory::Name())+1);
++#else
+ buf=strdup(OldName+strlen(VideoDirectory)+1);
++#endif
+ if(buf)
+ {
+ buf=ExchangeChars(buf,false);
+@@ -240,8 +244,13 @@
+ {
+ myRecListItem *item=(myRecListItem*)&ListObject;
+
++#if APIVERSNUM > 20101
++ char *s1=StripEpisodeName(strdup(filename+strlen(cVideoDirectory::Name())));
++ char *s2=StripEpisodeName(strdup(item->filename+strlen(cVideoDirectory::Name())));
++#else
+ char *s1=StripEpisodeName(strdup(filename+strlen(VideoDirectory)));
+ char *s2=StripEpisodeName(strdup(item->filename+strlen(VideoDirectory)));
++#endif
+
+ int compare;
+ if(mysetup.DescendSorting)
+@@ -699,7 +708,11 @@
+
+ isyslog("[extrecmenu] moving canceled");
+
++#if APIVERSNUM > 20101
++ cVideoDirectory::RemoveVideoFile(To.c_str());
++#else
+ RemoveVideoFile(To.c_str());
++#endif
+
+ return true;
+ }