summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-pvr-vbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/kodi-pvr-vbox
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/kodi-pvr-vbox')
-rw-r--r--media-plugins/kodi-pvr-vbox/Manifest4
-rw-r--r--media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-4.0.2.ebuild37
-rw-r--r--media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-9999.ebuild37
-rw-r--r--media-plugins/kodi-pvr-vbox/metadata.xml12
4 files changed, 90 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-vbox/Manifest b/media-plugins/kodi-pvr-vbox/Manifest
new file mode 100644
index 000000000000..7c770fd2102a
--- /dev/null
+++ b/media-plugins/kodi-pvr-vbox/Manifest
@@ -0,0 +1,4 @@
+DIST kodi-pvr-vbox-4.0.2.tar.gz 150156 SHA256 9fdf46384bf76e62596609519aa3c8b8b727ccb5d5e53cf296629067646cb731 SHA512 2b46cd6090764660c25a8c229bc11c23b0b200e4eecc6682a89f2754f6869217b93600ac5eb7a48b7d9183ca6eb237e1a396902b84493668c7045a6b4eb23a6e WHIRLPOOL 0f5d2884a313b45758053188dbcf6b0364166d0c84cd8798173b51e69b8251adb843dfed2174a21196c69a98009bcd7f8a890594a589697d53294b25099f8436
+EBUILD kodi-pvr-vbox-4.0.2.ebuild 660 SHA256 854becb6aa289b96062581dfdc8b7302673bfe19e0325bbd2038d4f355a094d5 SHA512 1d05297c4899eb4887f7ffa42fdc10d06480586b499f2640e89d9bcc1178d9c2e7f029d769e395460c3ddb4ca9d4064b1613c182a3e251dc7d746ad30dc91e1a WHIRLPOOL feee3fb07bbdd715666051c103efffa74ed9689fff0ca4b79a6983dd5ea5e1d8eebdfb19071d1b7d62f41c3026d3114f28dd7f370d56f068144e595542acef10
+EBUILD kodi-pvr-vbox-9999.ebuild 660 SHA256 854becb6aa289b96062581dfdc8b7302673bfe19e0325bbd2038d4f355a094d5 SHA512 1d05297c4899eb4887f7ffa42fdc10d06480586b499f2640e89d9bcc1178d9c2e7f029d769e395460c3ddb4ca9d4064b1613c182a3e251dc7d746ad30dc91e1a WHIRLPOOL feee3fb07bbdd715666051c103efffa74ed9689fff0ca4b79a6983dd5ea5e1d8eebdfb19071d1b7d62f41c3026d3114f28dd7f370d56f068144e595542acef10
+MISC metadata.xml 444 SHA256 1532297e565f96f695b4c513935d36d57fa67ed7e176b89eb0175d3922e358b7 SHA512 9c7992961c43a1e7bbc60018b282f41796dd8d0ba1127d6cafe0945127c2e65653fad5e47b2f283bf04ef9d3436d8693b6aee31513ae17fc98c245f97c9e3dbc WHIRLPOOL 5d87cda628c3855edb2dbcaa246bc06b813319ece02869ee6302963bec67085cdf940a9b1d848c51ecbfb565657224a3519379a729b5a0dd85fe21411f1d8df4
diff --git a/media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-4.0.2.ebuild b/media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-4.0.2.ebuild
new file mode 100644
index 000000000000..ca7823da941b
--- /dev/null
+++ b/media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-4.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's VBox Home TV Gateway PVR client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.vbox"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.vbox.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.vbox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.vbox-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ dev-libs/tinyxml2
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-9999.ebuild b/media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-9999.ebuild
new file mode 100644
index 000000000000..ca7823da941b
--- /dev/null
+++ b/media-plugins/kodi-pvr-vbox/kodi-pvr-vbox-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's VBox Home TV Gateway PVR client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.vbox"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.vbox.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.vbox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.vbox-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-libs/kodi-platform
+ dev-libs/tinyxml2
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-vbox/metadata.xml b/media-plugins/kodi-pvr-vbox/metadata.xml
new file mode 100644
index 000000000000..6409da1319f0
--- /dev/null
+++ b/media-plugins/kodi-pvr-vbox/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>Kodi's VBox Home TV Gateway PVR client addon</longdescription>
+ <upstream>
+ <remote-id type="github">kodi-pvr/pvr.vbox</remote-id>
+ </upstream>
+</pkgmetadata>