summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-pvr-mythtv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/kodi-pvr-mythtv
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/kodi-pvr-mythtv')
-rw-r--r--media-plugins/kodi-pvr-mythtv/Manifest4
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.15.3.ebuild36
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild36
-rw-r--r--media-plugins/kodi-pvr-mythtv/metadata.xml12
4 files changed, 88 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-mythtv/Manifest b/media-plugins/kodi-pvr-mythtv/Manifest
new file mode 100644
index 000000000000..193d816981a4
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/Manifest
@@ -0,0 +1,4 @@
+DIST kodi-pvr-mythtv-4.15.3.tar.gz 650217 SHA256 fd60aba0dac25ab5885371495a5dfca53308c1fa23215299b0f62997c7391e1e SHA512 1171f4e6a05878660795b585185d35707ef713e310f3508e7fb3327caf79feb6a941e4b4f4d9f2331ef13492c141a4d36157547e350642eee900f3fad1d46b55 WHIRLPOOL cc90104def6a1f5dc374fd0abfb4302057dde79d67fd6aa21417d97ccba130312a0b41858608af372860010482e84e6c957ff0a7f8c3a4c8d6949125d58e08f2
+EBUILD kodi-pvr-mythtv-4.15.3.ebuild 642 SHA256 15f235e909f80578e83719115d5ba200dee34a83e683ce2bb6baf0d1aa0bfbb5 SHA512 a5538514f1395a1f736ab751d46cadf5472c3db443ed8ee61b6ed021c358b93b5262cf1cc123c032e4ce3883a73ee677f4e7872190ff971506f2130f4c859283 WHIRLPOOL 31d381a3dcc9dbba2bc2102e778392e6555767a45f1d1925c1af0b2b9726ceee580a814001a7c20a441d6ef384f17cc4c9f8bb314b6a7cbd4fdbfe3439dc9141
+EBUILD kodi-pvr-mythtv-9999.ebuild 644 SHA256 b6968e89f94ec9f3c8eb00817ed69b8d84691c02b33a5d9f622a8a936b5d593f SHA512 967821ea4ee29e20e4b0cce5c7044197d1cb8ab9d2e88a30c4b5efe6736e876fb9e31192eed7e6b356406db1599a6472e4bb238b48624686930a16622ce326ae WHIRLPOOL 4f01f00ae489d569ec8f4f283713b8f9a79faf8c7b2486c32d889c5a635196e15f702df164a3650a28ff96664e1c0a2f4675e62d67b814d7e5afa745352e8fbf
+MISC metadata.xml 419 SHA256 1172daa86ac43044d8b7dd04b3c7e320fe274eb6338a7b2a09cfbde8f65c5076 SHA512 5b6c21c0e780ed90e92fb080f0a15cf62fee13e8b8597081f7b5480eb21f3f013495aafb389a302a227e6e22b757cc6b83d3dd56d7cd74ed16587edb09ef871e WHIRLPOOL 96b150346bf4801e22762b6d43de64f65ae6563c5fb2186d31c81b0228c707129d9fa347cb0f3d93c1f328d1a38788f7f0995870971d387f9b9cbe631ee489f9
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.15.3.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.15.3.ebuild
new file mode 100644
index 000000000000..0b183188b03a
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-4.15.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ sys-libs/zlib
+ =media-tv/kodi-17*
+ =media-libs/kodi-platform-17*
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
new file mode 100644
index 000000000000..4a54f66b3130
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ sys-libs/zlib
+ =media-tv/kodi-9999
+ =media-libs/kodi-platform-9999
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-mythtv/metadata.xml b/media-plugins/kodi-pvr-mythtv/metadata.xml
new file mode 100644
index 000000000000..1577ea89588e
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>MythTV PVR for Kodi</longdescription>
+ <upstream>
+ <remote-id type="github">janbar/pvr.mythtv</remote-id>
+ </upstream>
+</pkgmetadata>