summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild')
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
new file mode 100644
index 000000000000..e22f7487e303
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Krypton"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ =media-libs/kodi-platform-9999
+ =media-tv/kodi-9999
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "