summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild
new file mode 100644
index 000000000000..c7798ff8774b
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/inputstream.rtmp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare(){
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}