summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild
new file mode 100644
index 000000000000..28f7ef29d680
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/inputstream.rtmp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "