summaryrefslogtreecommitdiff
path: root/media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild')
-rw-r--r--media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild b/media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild
new file mode 100644
index 000000000000..862f2c55f029
--- /dev/null
+++ b/media-plugins/gimp-lqr/gimp-lqr-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit autotools eutils
+
+MY_P="${PN}-plugin-${PV}"
+
+DESCRIPTION="Content-aware resizing for the GIMP"
+HOMEPAGE="http://liquidrescale.wikidot.com/"
+SRC_URI="http://liquidrescale.wikidot.com/local--files/en:download-page-sources/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-gfx/gimp
+ media-libs/liblqr"
+DEPEND="dev-util/intltool
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-no-deprecated.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}