summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /media-libs
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Manifest.gzbin68107 -> 68265 bytes
-rw-r--r--media-libs/jg/Manifest4
-rw-r--r--media-libs/jg/jg-1.0.0.ebuild28
-rw-r--r--media-libs/jg/jg-9999.ebuild28
-rw-r--r--media-libs/jg/metadata.xml23
-rw-r--r--media-libs/openh264/Manifest2
-rw-r--r--media-libs/openh264/openh264-2.3.1-r1.ebuild2
7 files changed, 85 insertions, 2 deletions
diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index ace5495fb1e8..a0922691094e 100644
--- a/media-libs/Manifest.gz
+++ b/media-libs/Manifest.gz
Binary files differ
diff --git a/media-libs/jg/Manifest b/media-libs/jg/Manifest
new file mode 100644
index 000000000000..00b94309d9a1
--- /dev/null
+++ b/media-libs/jg/Manifest
@@ -0,0 +1,4 @@
+DIST jg-1.0.0.tar.bz2 12540 BLAKE2B 0f50221737a3bf294731e593988f9e6314291b3ab8389610ce0a0b6d8bf870dc49312b3129ff1479fde518ab35aeb47b172022c0630b09903a384a6d95c5ba0c SHA512 183766714279fe9fc30887d92ca533931a9906f53b4b8c2c8032914fa375e5f40f540ba4c2c32569f5ed956f108eb1e483227e42b59fb08fea6872fe9526b4fb
+EBUILD jg-1.0.0.ebuild 592 BLAKE2B a94faad1f2313033dc65f8ebcd4b34ceed1e62d135a4071c9408db1c7b730412606d79f085ad7d70f4fa5ba7eeee6d0d5732c6931bae00b5ceb5b8f7af72be52 SHA512 60b4be4cdc6e4f731bbbeca28e69332fc97400ffe88fa9438add89490ab578c13da0415e28e0fc071b764731ffcbdf2895a5597fec23a307be34f8c6f6bea999
+EBUILD jg-9999.ebuild 592 BLAKE2B a94faad1f2313033dc65f8ebcd4b34ceed1e62d135a4071c9408db1c7b730412606d79f085ad7d70f4fa5ba7eeee6d0d5732c6931bae00b5ceb5b8f7af72be52 SHA512 60b4be4cdc6e4f731bbbeca28e69332fc97400ffe88fa9438add89490ab578c13da0415e28e0fc071b764731ffcbdf2895a5597fec23a307be34f8c6f6bea999
+MISC metadata.xml 793 BLAKE2B e1da0494738ce82ea8e2cc4798fe5eace66762de4140f4304f99cb8c85bb64e5d73324e59fc31f96586a398ca9066d1bbcf6eb5e55b1dd29bebdc6e46c71e6cd SHA512 ce0346a4d32c594d4f7811b61b03b7386df2899ed403b8a9e6442c9d633419b35b79d0330fb5ff3aee1805dd26ff638f8b11ed59fd95301a2c10e24f00a498c2
diff --git a/media-libs/jg/jg-1.0.0.ebuild b/media-libs/jg/jg-1.0.0.ebuild
new file mode 100644
index 000000000000..9f2cd2137949
--- /dev/null
+++ b/media-libs/jg/jg-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference Implementation of The Jolly Good API"
+HOMEPAGE="https://jgemu.gitlab.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZLIB"
+SLOT="1"
+
+src_compile() {
+ : # Nothing to do
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+}
diff --git a/media-libs/jg/jg-9999.ebuild b/media-libs/jg/jg-9999.ebuild
new file mode 100644
index 000000000000..9f2cd2137949
--- /dev/null
+++ b/media-libs/jg/jg-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference Implementation of The Jolly Good API"
+HOMEPAGE="https://jgemu.gitlab.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZLIB"
+SLOT="1"
+
+src_compile() {
+ : # Nothing to do
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+}
diff --git a/media-libs/jg/metadata.xml b/media-libs/jg/metadata.xml
new file mode 100644
index 000000000000..4525b8490bca
--- /dev/null
+++ b/media-libs/jg/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Jolly Good API is an emulation focused API for
+ rshared objects, written in ISO C99. It has been
+ designed with the goal of simplicity to ensure that
+ emulator cores are lean and minimalistic, making
+ them easier to understand.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/jg/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/jg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/openh264/Manifest b/media-libs/openh264/Manifest
index 56a4a82e89f0..870245dd383e 100644
--- a/media-libs/openh264/Manifest
+++ b/media-libs/openh264/Manifest
@@ -3,5 +3,5 @@ DIST gmp-api-Firefox39-3a01c086d1b0394238ff1b5ad22e76022830625a.tar.gz 10464 BLA
DIST openh264-2.3.0.tar.gz 60290792 BLAKE2B 08aa571471188c72bb0f098fa1cfaf9ba46ee4311f50518de868a2d7bbd61d9d4547cf5d33b3140d56c09a1ea7ea411bfaa96ed960e159876e6cc803f081b5d3 SHA512 5f0ccbb3c0026a010d9830e973312486f9d5ea8152afa3653ab6b3c43906a1169cebea70532134c1624846cc03b586e85b12cfd0621af505bd532a7dd833defd
DIST openh264-2.3.1.tar.gz 60290897 BLAKE2B b4480150cfe7c44b89c7b294698db06f93d96f5f9f3ef4345108c4e360e99bc6133407cead54e720e6e74aa17ab9f2e4342287a42f19463a54eb44c9d3141c80 SHA512 fd59c767794cdfb934d692d5929e4500d78606cbf1e403bc7c7dce048cc07e40daa0794357adb856d29479427a53460c76338e156b6bbeaa36139afcd603c8e1
EBUILD openh264-2.3.0.ebuild 3618 BLAKE2B 9ea4acd09a5c2281a99a576974bf3d0348fd54377349a68fb94ff983051a6f27a4a59c8b756124e48cdab8e92dfa336558e804ab80da4fd15cb271428de45977 SHA512 6cc32135588b0da11776558c210e7bc8ddca89f4028d4ad1fe283c046b08b058eac6404320937f7d1c6e3ac17fbaa14f7f04f505a1915d68fa2b393c72691efa
-EBUILD openh264-2.3.1-r1.ebuild 3626 BLAKE2B 7e75fe73ee51d62bbb5bc3e02e1b84456659e6c541b7c9865ecf5624f456ab4c17da98fb0f164b7112969b7ef17137a29ed8b414b23ffe4acf87163ed25191b8 SHA512 11beb34de4df806d9ae81988f2573fa46fa1d4b918a806f20bf8e76c3efa3758f89c17653b35dcabdb7972a606436b13da7c098810f1ce2223069c400b0e2f37
+EBUILD openh264-2.3.1-r1.ebuild 3623 BLAKE2B 24cd5a158dcb25d0ed87b54fe62b3fa552ea8b89f5f007fb96d8274923dce770a65627c4f39c49680a7d26c953f1ff8a7c857cb23d6e71adc48d10a8303038f9 SHA512 4f37e69ba640d24999623d1c0492547d3912694c633be34412b130593e527dd712d8bf6de1f047584f9a1230281078d2239a4c171f6d96d7150fb1e906bc1f5d
MISC metadata.xml 569 BLAKE2B 14a021fba978f0156bab46178d05a6b9f8f67fdeba784d587759207fe60ea1d74a383eec3fc40662c39d33fcecb71d8cafe7eb6354383c253e0a3f7f1e94feae SHA512 ceb77117c6a50f16640b329368c86db26127b8e501475dbaca4c53ba41315b0fc7161f6d9268cb86d1f6dbf2cf867e2bb0e6b5f45240ab3227b99b734c344efd
diff --git a/media-libs/openh264/openh264-2.3.1-r1.ebuild b/media-libs/openh264/openh264-2.3.1-r1.ebuild
index 61262aaa914f..0bb5fa26460b 100644
--- a/media-libs/openh264/openh264-2.3.1-r1.ebuild
+++ b/media-libs/openh264/openh264-2.3.1-r1.ebuild
@@ -18,7 +18,7 @@ LICENSE="BSD"
# (2.2.0 needed a minor bump due to undocumented but breaking ABI changes, just to be sure.
# https://github.com/cisco/openh264/issues/3459 )
SLOT="0/7"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
IUSE="cpu_flags_arm_neon cpu_flags_x86_avx2 +plugin utils"
RESTRICT="bindist test"