summaryrefslogtreecommitdiff
path: root/media-libs/xine-lib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/xine-lib/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/xine-lib/files')
-rw-r--r--media-libs/xine-lib/files/ffmpeg29.patch44
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.6-imagemagick7.patch13
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch25
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch15
4 files changed, 97 insertions, 0 deletions
diff --git a/media-libs/xine-lib/files/ffmpeg29.patch b/media-libs/xine-lib/files/ffmpeg29.patch
new file mode 100644
index 000000000000..a220483218c0
--- /dev/null
+++ b/media-libs/xine-lib/files/ffmpeg29.patch
@@ -0,0 +1,44 @@
+Index: xine-lib-1.2.6/src/combined/ffmpeg/ff_audio_decoder.c
+===================================================================
+--- xine-lib-1.2.6.orig/src/combined/ffmpeg/ff_audio_decoder.c
++++ xine-lib-1.2.6/src/combined/ffmpeg/ff_audio_decoder.c
+@@ -590,7 +590,7 @@ static int ff_audio_decode (ff_audio_dec
+ int got_frame;
+ float gain = this->class->gain;
+ if (!this->av_frame)
+- this->av_frame = avcodec_alloc_frame ();
++ this->av_frame = av_frame_alloc ();
+
+ consumed = avcodec_decode_audio4 (this->context, this->av_frame, &got_frame, &avpkt);
+ if ((consumed >= 0) && got_frame) {
+@@ -1071,7 +1071,7 @@ static void ff_audio_reset (audio_decode
+ /* try to reset the wma decoder */
+ if( this->decoder_ok ) {
+ #if AVAUDIO > 3
+- avcodec_free_frame (&this->av_frame);
++ av_frame_free (&this->av_frame);
+ #endif
+ pthread_mutex_lock (&ffmpeg_lock);
+ avcodec_close (this->context);
+@@ -1105,7 +1105,7 @@ static void ff_audio_dispose (audio_deco
+
+ if( this->context && this->decoder_ok ) {
+ #if AVAUDIO > 3
+- avcodec_free_frame (&this->av_frame);
++ av_frame_free (&this->av_frame);
+ #endif
+ pthread_mutex_lock (&ffmpeg_lock);
+ avcodec_close (this->context);
+Index: xine-lib-1.2.6/src/combined/ffmpeg/ff_video_decoder.c
+===================================================================
+--- xine-lib-1.2.6.orig/src/combined/ffmpeg/ff_video_decoder.c
++++ xine-lib-1.2.6/src/combined/ffmpeg/ff_video_decoder.c
+@@ -2523,7 +2523,7 @@ static video_decoder_t *ff_video_open_pl
+ this->stream = stream;
+ this->class = (ff_video_class_t *) class_gen;
+
+- this->av_frame = avcodec_alloc_frame();
++ this->av_frame = av_frame_alloc();
+ this->context = avcodec_alloc_context();
+ this->context->opaque = this;
+ #if AVPALETTE == 1
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.6-imagemagick7.patch b/media-libs/xine-lib/files/xine-lib-1.2.6-imagemagick7.patch
new file mode 100644
index 000000000000..34062222e32c
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.2.6-imagemagick7.patch
@@ -0,0 +1,13 @@
+http://git.pld-linux.org/?p=packages/xine-lib.git;a=blob;f=imagemagick7.patch;h=d050323cdf509c9bb5f8edbad90084e8ce5c1b38;hb=HEAD
+
+--- xine-lib-1.2.6/src/video_dec/image.c
++++ xine-lib-1.2.6/src/video_dec/image.c
+@@ -39,7 +39,7 @@
+ #define LOG
+ */
+
+-#include <wand/magick_wand.h>
++#include <MagickWand/MagickWand.h>
+ #ifdef PACKAGE_NAME
+ #undef PACKAGE_BUGREPORT
+ #undef PACKAGE_NAME
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch b/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch
new file mode 100644
index 000000000000..cc17643d9c56
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch
@@ -0,0 +1,25 @@
+https://bugs.xine-project.org/show_bug.cgi?id=572
+https://bugs.gentoo.org/584640
+
+--- xine-lib-1.2.6/m4/video_out.m4
++++ xine-lib-1.2.6/m4/video_out.m4
+@@ -305,7 +305,7 @@
+ dnl xcb
+ XINE_ARG_WITH([xcb], [Enable support for XCB video out plugins])
+ if test x"$with_xcb" != x"no"; then
+- PKG_CHECK_MODULES([XCB], [xcb-shape >= 1.0], [have_xcb=yes], [have_xcb=no])
++ PKG_CHECK_MODULES([XCB], [xcb xcb-shape >= 1.0], [have_xcb=yes], [have_xcb=no])
+ if test x"$hard_enable_xcb" = x"yes" && test x"$have_xcb" != x"yes"; then
+ AC_MSG_ERROR([XCB support requested, but XCB not found])
+ elif test x"$have_xcb" = x"yes"; then
+--- xine-lib-1.2.6/src/video_out/Makefile.am
++++ xine-lib-1.2.6/src/video_out/Makefile.am
+@@ -147,7 +147,7 @@
+ xineplug_vo_out_xcbshm_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS) $(XCBSHM_CFLAGS) $(AVUTIL_CFLAGS)
+
+ xineplug_vo_out_xcbxv_la_SOURCES = video_out_xcbxv.c $(XCBOSD)
+-xineplug_vo_out_xcbxv_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL) $(XCBXV_LIBS) $(XCB_LIBS)
++xineplug_vo_out_xcbxv_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL) $(XCBXV_LIBS) $(XCBSHM_LIBS) $(XCB_LIBS)
+ xineplug_vo_out_xcbxv_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS) $(XCBXV_CFLAGS)
+
+ xineplug_vo_out_xshm_la_SOURCES = video_out_xshm.c $(X11OSD)
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch b/media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch
new file mode 100644
index 000000000000..a7168d5b4506
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch
@@ -0,0 +1,15 @@
+fix build w/newer glibc due to major/minor includes being dropped from sys/types.h
+
+https://bugs.gentoo.org/580012
+https://bugs.xine-project.org/show_bug.cgi?id=574
+
+--- a/src/xine-utils/xine_check.c
++++ b/src/xine-utils/xine_check.c
+@@ -55,6 +55,7 @@
+ #include <dlfcn.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
++#include <sys/sysmacros.h>
+ #include <sys/utsname.h>
+ #include <linux/major.h>
+ #include <linux/hdreg.h>