summaryrefslogtreecommitdiff
path: root/media-libs/x265/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-libs/x265/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-libs/x265/files')
-rw-r--r--media-libs/x265/files/arm.patch34
-rw-r--r--media-libs/x265/files/non_x86.patch20
-rw-r--r--media-libs/x265/files/ppc64.patch15
-rw-r--r--media-libs/x265/files/x265-2.9-detect512.patch25
-rw-r--r--media-libs/x265/files/x265-3.3-arm.patch34
-rw-r--r--media-libs/x265/files/x265-3.3-neon.patch16
6 files changed, 0 insertions, 144 deletions
diff --git a/media-libs/x265/files/arm.patch b/media-libs/x265/files/arm.patch
deleted file mode 100644
index 69edcdecfb91..000000000000
--- a/media-libs/x265/files/arm.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-More aliases for ARM.
-Do not force CFLAGS for ARM.
-
-Index: source/CMakeLists.txt
-===================================================================
---- source.orig/CMakeLists.txt
-+++ source/CMakeLists.txt
-@@ -41,7 +41,7 @@ SET(CMAKE_MODULE_PATH "${PROJECT_SOURCE_
- # System architecture detection
- string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
- set(X86_ALIASES x86 i386 i686 x86_64 amd64)
--set(ARM_ALIASES armv6l armv7l)
-+set(ARM_ALIASES armv6l armv6j armv7l armv7a)
- list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
- list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
- set(POWER_ALIASES ppc64 ppc64le)
-@@ -208,15 +208,11 @@ if(GCC)
- endif()
- endif()
- endif()
-- if(ARM AND CROSS_COMPILE_ARM)
-- set(ARM_ARGS -march=armv6 -mfloat-abi=soft -mfpu=vfp -marm -fPIC)
-- elseif(ARM)
-+ if(ARM)
- find_package(Neon)
- if(CPU_HAS_NEON)
-- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=neon -marm -fPIC)
-+ set(ARM_ARGS -mfpu=neon)
- add_definitions(-DHAVE_NEON)
-- else()
-- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=vfp -marm)
- endif()
- endif()
- add_definitions(${ARM_ARGS})
diff --git a/media-libs/x265/files/non_x86.patch b/media-libs/x265/files/non_x86.patch
deleted file mode 100644
index 3c7e389329a7..000000000000
--- a/media-libs/x265/files/non_x86.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-# HG changeset patch
-# User Jayashree <jayashree.c@multicorewareinc.com>
-# Date 1527224165 -19800
-# Fri May 25 10:26:05 2018 +0530
-# Node ID 4504219210793536d921ee4e0b3058698c630bf4
-# Parent cc2c5e46f3c87d27e3602af30b06ba6a0fbe2704
-Fix build error on on ppc64le
-
-diff -r cc2c5e46f3c8 -r 450421921079 source/common/param.cpp
---- a/source/common/param.cpp Mon May 21 18:42:29 2018 +0530
-+++ b/source/common/param.cpp Fri May 25 10:26:05 2018 +0530
-@@ -633,7 +633,7 @@
- if (bValueWasNull)
- p->cpuid = atobool(value);
- else
-- p->cpuid = parseCpuName(value, bError);
-+ p->cpuid = parseCpuName(value, bError, false);
- #endif
- }
- OPT("fps")
diff --git a/media-libs/x265/files/ppc64.patch b/media-libs/x265/files/ppc64.patch
deleted file mode 100644
index f453c0de0a57..000000000000
--- a/media-libs/x265/files/ppc64.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-More complete ppc64 matches.
-
-Index: x265_2.2/source/CMakeLists.txt
-===================================================================
---- x265_2.2.orig/source/CMakeLists.txt
-+++ x265_2.2/source/CMakeLists.txt
-@@ -44,7 +44,7 @@ set(X86_ALIASES x86 i386 i686 x86_64 amd
- set(ARM_ALIASES armv6l armv6j armv7l armv7a)
- list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
- list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
--set(POWER_ALIASES ppc64 ppc64le)
-+set(POWER_ALIASES ppc64 ppc64le powerpc64 powerpc64le)
- list(FIND POWER_ALIASES "${SYSPROC}" POWERMATCH)
- if("${SYSPROC}" STREQUAL "" OR X86MATCH GREATER "-1")
- set(X86 1)
diff --git a/media-libs/x265/files/x265-2.9-detect512.patch b/media-libs/x265/files/x265-2.9-detect512.patch
deleted file mode 100644
index 8437ed09b884..000000000000
--- a/media-libs/x265/files/x265-2.9-detect512.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/source/common/cpu.cpp
-+++ b/source/common/cpu.cpp
-@@ -110,6 +110,11 @@
- { "", 0 },
- };
-
-+bool detect512()
-+{
-+ return(enable512);
-+}
-+
- #if X265_ARCH_X86
-
- extern "C" {
-@@ -123,10 +128,6 @@
- #pragma warning(disable: 4309) // truncation of constant value
- #endif
-
--bool detect512()
--{
-- return(enable512);
--}
- uint32_t cpu_detect(bool benableavx512 )
- {
-
diff --git a/media-libs/x265/files/x265-3.3-arm.patch b/media-libs/x265/files/x265-3.3-arm.patch
deleted file mode 100644
index 7e7c8c58b724..000000000000
--- a/media-libs/x265/files/x265-3.3-arm.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-More aliases for ARM.
-Do not force CFLAGS for ARM.
-
-Index: source/CMakeLists.txt
-===================================================================
---- old/CMakeLists.txt
-+++ new/CMakeLists.txt
-@@ -41,7 +41,7 @@ SET(CMAKE_MODULE_PATH "${PROJECT_SOURCE_
- # System architecture detection
- string(TOLOWER "${CMAKE_SYSTEM_PROCESSOR}" SYSPROC)
- set(X86_ALIASES x86 i386 i686 x86_64 amd64)
--set(ARM_ALIASES armv6l armv7l)
-+set(ARM_ALIASES armv6l armv6j armv7l armv7a)
- list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
- list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
- set(POWER_ALIASES ppc64 ppc64le)
-@@ -208,15 +208,11 @@ if(GCC)
- endif()
- endif()
- endif()
-- if(ARM AND CROSS_COMPILE_ARM)
-- set(ARM_ARGS -march=armv6 -mfloat-abi=soft -mfpu=vfp -marm -fPIC)
-- elseif(ARM)
-+ if(ARM)
- find_package(Neon)
- if(CPU_HAS_NEON)
-- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=neon -marm -fPIC)
-+ set(ARM_ARGS -mfpu=neon)
- add_definitions(-DHAVE_NEON)
-- else()
-- set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=vfp -marm)
- endif()
- endif()
- add_definitions(${ARM_ARGS})
diff --git a/media-libs/x265/files/x265-3.3-neon.patch b/media-libs/x265/files/x265-3.3-neon.patch
deleted file mode 100644
index 316e670febe3..000000000000
--- a/media-libs/x265/files/x265-3.3-neon.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-These functions are only built when enabling assembly on ARM; use proper check
-to avoid undefined symbols.
-
-Index: source/common/primitives.cpp
-===================================================================
---- old/common/primitives.cpp
-+++ new/common/primitives.cpp
-@@ -270,7 +270,7 @@ void PFX(cpu_emms)(void) {}
- void PFX(cpu_cpuid)(uint32_t, uint32_t *eax, uint32_t *, uint32_t *, uint32_t *) { *eax = 0; }
- void PFX(cpu_xgetbv)(uint32_t, uint32_t *, uint32_t *) {}
-
--#if X265_ARCH_ARM == 0
-+#if X265_ARCH_ARM == 0 || !defined(ENABLE_ASSEMBLY)
- void PFX(cpu_neon_test)(void) {}
- int PFX(cpu_fast_neon_mrc_test)(void) { return 0; }
- #endif // X265_ARCH_ARM