summaryrefslogtreecommitdiff
path: root/media-libs/x264
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-libs/x264
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/Manifest2
-rw-r--r--media-libs/x264/x264-0.0.20190903.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/x264/Manifest b/media-libs/x264/Manifest
index 4d5b6895271e..2d8329a310d9 100644
--- a/media-libs/x264/Manifest
+++ b/media-libs/x264/Manifest
@@ -1,4 +1,6 @@
DIST x264-snapshot-20190214-2245.tar.bz2 770462 BLAKE2B d90a3bafb88febe12526b225617616a62c32fa3d3eacf410267e1fbd7e0fafaadca7c146172c08fc525bce8791d81c7d87dc27b06d61a6a44bf2ad92f6c1def6 SHA512 c8b1b46d4e6c0ef653dab35083a454c635ebf72c6a5255ce30bbb5d9d6bb8e23fca0e6cc197ea99f3c702fbfec096587df6fa82dec338d8bd45e35fa89c43039
+DIST x264-snapshot-20190903-2245.tar.bz2 774515 BLAKE2B 0b19fc1d3cedea32bfac9c5247bce7b3c04dead35458d61f3b5c0694040dc852b0110b620faf4118ed265a5605aafce3c49d468d38fb91e4c515b2860c486920 SHA512 c357c9025ffdf653c974eb7ccc2e9a4de86c02881372a6a8270ae59ce948c284da48a2aba37763bd29359d2a6dfc76ea56a52fed6082f8483912c8f948488a2d
EBUILD x264-0.0.20190214.ebuild 1815 BLAKE2B ef9a8e82e7859922afc7f496a7a70b5ebdd01442bd11b5990b14b6a5384faf87123529398ed8bdc21f1685eed839aeb5cbd4ad9614c6073d0dd0e0f04651d9b1 SHA512 9d1e2c6ae46dd73d71929e1d46eea7f8e63517653b17aa3d88b884cd59a1b3fb1646560363e52c517eaf33afc11ca9f6b36d094162259faea8b2aee94bbf8f58
+EBUILD x264-0.0.20190903.ebuild 1824 BLAKE2B dc38712d74f047f47b84e99ad9f2c78c5d452fbc7dd8e503d0f74136559fe5e5b3e858a7edb1dc7210e46935d1af02fd0966b984cd2dcfc8ad20c8c1d6cc5286 SHA512 8b4d908028140b4b592e556a338abbe92143b80381008e34b9a2e822e009537c22a2544d36b9ab5cf1bcbc5d33ad329cf6353c099201cd3365bde9258f6a4cd4
EBUILD x264-9999.ebuild 1824 BLAKE2B dc38712d74f047f47b84e99ad9f2c78c5d452fbc7dd8e503d0f74136559fe5e5b3e858a7edb1dc7210e46935d1af02fd0966b984cd2dcfc8ad20c8c1d6cc5286 SHA512 8b4d908028140b4b592e556a338abbe92143b80381008e34b9a2e822e009537c22a2544d36b9ab5cf1bcbc5d33ad329cf6353c099201cd3365bde9258f6a4cd4
MISC metadata.xml 488 BLAKE2B 3e6982e1bbd45194bb664ddb4b34e307ef4030f4fba9905d0a292c8a5ce73e27bc1c687758cc4fb18d38cc2c93ed21b64dfa35b2aaa63dc6fbd1110b9e1daf1f SHA512 2dc9d360de31770d2e8eebc3bab9662a00ad328ba41380052c3e7502a4da85c7b0ce29cf229670d917c93d7b508282dd9f1694a718da65f1110c785a2bc68394
diff --git a/media-libs/x264/x264-0.0.20190903.ebuild b/media-libs/x264/x264-0.0.20190903.ebuild
new file mode 100644
index 000000000000..ee5e6ace2cd2
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20190903.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="https://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/x264.git"
+else
+ MY_P="x264-snapshot-$(ver_cut 3)-2245"
+ SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+SLOT="0/157" # SONAME
+
+LICENSE="GPL-2"
+IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+
+ASM_DEP=">=dev-lang/nasm-2.13"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )
+ opencl? ( dev-lang/perl )"
+RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
+
+multilib_src_configure() {
+ tc-export CC
+ local asm_conf=""
+
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
+ asm_conf=" --disable-asm"
+ fi
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ $(usex interlaced "" "--disable-interlaced") \
+ $(usex opencl "" "--disable-opencl") \
+ $(usex static-libs "--enable-static" "") \
+ $(usex threads "" "--disable-thread") \
+ ${asm_conf} || die
+}