summaryrefslogtreecommitdiff
path: root/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 16:50:39 +0100
commit3be8faef74cb863e207124a6fccbf01ce90c0799 (patch)
tree222958402b707645e8b7bcb072c607c538f2f5c0 /media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild
parentea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (diff)
gentoo auto-resync : 15:09:2023 - 16:50:39
Diffstat (limited to 'media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild')
-rw-r--r--media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild b/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..946115a3b322
--- /dev/null
+++ b/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="AudioProcessing library from the webrtc.org code base"
+HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+DOCS=( AUTHORS NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3-proper_detection_cxxabi_execinfo.patch
+ "${FILESDIR}"/${PN}-0.3-Add-generic-byte-order-and-pointer-size-detection.patch
+ "${FILESDIR}"/${PN}-0.3-big-endian-support.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}