summaryrefslogtreecommitdiff
path: root/media-libs/webrtc-audio-processing/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /media-libs/webrtc-audio-processing/files
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'media-libs/webrtc-audio-processing/files')
-rw-r--r--media-libs/webrtc-audio-processing/files/1.0-abseil-cmake.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/webrtc-audio-processing/files/1.0-abseil-cmake.patch b/media-libs/webrtc-audio-processing/files/1.0-abseil-cmake.patch
new file mode 100644
index 000000000000..ca1e825469a5
--- /dev/null
+++ b/media-libs/webrtc-audio-processing/files/1.0-abseil-cmake.patch
@@ -0,0 +1,69 @@
+From 3f9907f93d3983033e176e95f5134a57900a7f6e Mon Sep 17 00:00:00 2001
+From: Arun Raghavan <arun@asymptotic.io>
+Date: Thu, 10 Dec 2020 19:06:31 -0500
+Subject: [PATCH] build: Use cmake to look up abseil dependency
+
+This should be much more robust than looking up the library directly.
+
+Fixes: https://gitlab.freedesktop.org/pulseaudio/webrtc-audio-processing/-/issues/4
+---
+ .gitlab-ci.yml | 3 ++-
+ meson.build | 21 ++++++++-------------
+ 2 files changed, 10 insertions(+), 14 deletions(-)
+
+diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
+index 11a3b78..42cd589 100644
+--- a/.gitlab-ci.yml
++++ b/.gitlab-ci.yml
+@@ -19,7 +19,7 @@ variables:
+ # CI runs, for example when adding new packages to FDO_DISTRIBUTION_PACKAGES.
+ # The tag is an arbitrary string that identifies the exact container
+ # contents.
+- BASE_TAG: '2020-11-27.1'
++ BASE_TAG: '2020-12-10.1'
+ FDO_DISTRIBUTION_VERSION: '20.10'
+ FDO_UPSTREAM_REPO: 'pulseaudio/webrtc-audio-processing'
+
+@@ -43,6 +43,7 @@ include:
+ FDO_DISTRIBUTION_PACKAGES: >-
+ g++
+ gcc
++ cmake
+ libabsl-dev
+ meson
+ ninja-build
+diff --git a/meson.build b/meson.build
+index bae155e..96d84d7 100644
+--- a/meson.build
++++ b/meson.build
+@@ -40,19 +40,14 @@ os_deps = []
+ have_posix = false
+ have_win = false
+
+-absl_dep = [
+- cpp.find_library('absl_base'),
+- cpp.find_library('absl_bad_optional_access'),
+- cpp.find_library('absl_flags_internal'),
+- cpp.find_library('absl_flags_marshalling'),
+- cpp.find_library('absl_flags_parse'),
+- cpp.find_library('absl_flags_registry'),
+- cpp.find_library('absl_flags_usage_internal'),
+- cpp.find_library('absl_raw_logging_internal'),
+- cpp.find_library('absl_strings'),
+- cpp.find_library('absl_synchronization'),
+- cpp.find_library('absl_throw_delegate'),
+-]
++absl_dep = dependency('absl', method : 'cmake',
++ modules : [
++ 'absl::base',
++ 'absl::flags_parse',
++ 'absl::strings',
++ 'absl::synchronization',
++ ]
++)
+
+ if ['darwin', 'ios'].contains(host_system)
+ os_cflags = ['-DWEBRTC_MAC']
+--
+GitLab
+