summaryrefslogtreecommitdiff
path: root/media-libs/waffle/waffle-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/waffle/waffle-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/waffle/waffle-9999.ebuild')
-rw-r--r--media-libs/waffle/waffle-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index 7b4d01d42f65..a4611e934598 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
GIT_ECLASS="git-r3"
else
SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
S="${WORKDIR}"/${PN}-v${PV}
fi
-inherit meson-multilib ${GIT_ECLASS}
+inherit meson-multilib multilib ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
@@ -31,7 +31,7 @@ RDEPEND="
wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
- X? ( >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}] )
+ X? ( >=x11-base/xcb-proto-1.8-r3 )
"
BDEPEND="
dev-libs/libxslt