summaryrefslogtreecommitdiff
path: root/media-libs/waffle/waffle-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /media-libs/waffle/waffle-9999.ebuild
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'media-libs/waffle/waffle-9999.ebuild')
-rw-r--r--media-libs/waffle/waffle-9999.ebuild53
1 files changed, 34 insertions, 19 deletions
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index dc2a60608875..a7c32a6cf596 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/waffle-gl/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
GIT_ECLASS="git-r3"
else
- SRC_URI="https://people.freedesktop.org/~chadversary/${PN}/files/release/${P}/${P}.tar.xz"
+ SRC_URI="http://www.waffle-gl.org/files/release/${P}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
fi
-inherit cmake-multilib ${GIT_ECLASS}
+inherit meson multilib-minimal ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
-HOMEPAGE="https://people.freedesktop.org/~chadversary/waffle/"
+HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
LICENSE="BSD-2"
SLOT="0"
-IUSE="doc egl gbm test wayland"
+IUSE="doc egl gbm test wayland X"
+RESTRICT="test" # gl_basic tests don't work when run from portage
RDEPEND="
>=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
@@ -35,20 +36,34 @@ DEPEND="${RDEPEND}
)
"
-src_configure() {
- local mycmakeargs=(
- -Dwaffle_has_glx=ON
- -Dwaffle_build_examples=OFF
- -Dwaffle_build_manpages=$(usex doc )
- -Dwaffle_has_x11_egl=$(usex egl)
- -Dwaffle_has_gbm=$(usex gbm)
- -Dwaffle_build_tests=$(usex test)
- -Dwaffle_has_wayland=$(usex wayland)
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ $(meson_feature gbm)
+ $(meson_feature egl surfaceless_egl)
+ $(meson_use test build-tests)
+ $(meson_use doc build-manpages)
)
+ meson_src_configure
+}
- cmake-multilib_src_configure
+multilib_src_compile() {
+ meson_src_compile
}
-src_test() {
- emake -C "${CMAKE_BUILD_DIR}" check
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ rm -rf ${D}/usr/share/doc/waffle1
}