summaryrefslogtreecommitdiff
path: root/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild')
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
new file mode 100644
index 000000000000..cd5f549fefdc
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="https://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=yes
+fi
+
+inherit autotools-multilib flag-o-matic ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="examples static-libs cpu_flags_arm_neon"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_configure() {
+ use cpu_flags_arm_neon && append-flags '-mfpu=neon'
+ local myeconfargs=(
+ "$(use_enable examples example)"
+ "$(use_enable cpu_flags_arm_neon armv7neon)"
+ )
+ autotools-multilib_src_configure
+}