summaryrefslogtreecommitdiff
path: root/media-libs/vkroots/vkroots-0_p20221205-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 23:32:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 23:32:29 +0100
commit930b5a700c6f4093c4b63eec7395c080ab639311 (patch)
tree314e43df83fe12b5fa743c5aa37d0c7ae26260fc /media-libs/vkroots/vkroots-0_p20221205-r1.ebuild
parent8b5a92f1e1eccecfa61db8a4744e1b9d449522b6 (diff)
gentoo auto-resync : 05:05:2023 - 23:32:28
Diffstat (limited to 'media-libs/vkroots/vkroots-0_p20221205-r1.ebuild')
-rw-r--r--media-libs/vkroots/vkroots-0_p20221205-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-libs/vkroots/vkroots-0_p20221205-r1.ebuild b/media-libs/vkroots/vkroots-0_p20221205-r1.ebuild
new file mode 100644
index 000000000000..d41f02b5ac64
--- /dev/null
+++ b/media-libs/vkroots/vkroots-0_p20221205-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="e6b89494142eec0ac6061f82a947d2f1246d3d7a"
+DESCRIPTION="Simple framework for writing Vulkan layers"
+HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
+SRC_URI="https://github.com/Joshua-Ashton/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0 MIT LGPL-2.1"
+SLOT="0"
+
+RDEPEND="
+ dev-util/vulkan-headers
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+ default
+ insinto /usr/include/${PN}
+ doins ${PN}.h meson.build
+}