summaryrefslogtreecommitdiff
path: root/media-libs/vigra/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-libs/vigra/files
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-libs/vigra/files')
-rw-r--r--media-libs/vigra/files/vigra-1.11.1-boost-python.patch22
-rw-r--r--media-libs/vigra/files/vigra-1.11.1-cmake-module-dir.patch17
-rw-r--r--media-libs/vigra/files/vigra-1.11.1-python3.7.patch30
-rw-r--r--media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch27
4 files changed, 96 insertions, 0 deletions
diff --git a/media-libs/vigra/files/vigra-1.11.1-boost-python.patch b/media-libs/vigra/files/vigra-1.11.1-boost-python.patch
new file mode 100644
index 000000000000..ffa3334f873a
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.11.1-boost-python.patch
@@ -0,0 +1,22 @@
+From 32ce9bc334580de7df3a97b106189145744e3726 Mon Sep 17 00:00:00 2001
+From: Ullrich Koethe <ullrich.koethe@iwr.uni-heidelberg.de>
+Date: Tue, 16 Oct 2018 19:10:56 +0200
+Subject: [PATCH] cmake: add boost_python${MAJOR}${MINOR} (fixes #445)
+
+---
+ config/FindVIGRANUMPY_DEPENDENCIES.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/config/FindVIGRANUMPY_DEPENDENCIES.cmake b/config/FindVIGRANUMPY_DEPENDENCIES.cmake
+index f6f9d563b..47cf4237c 100644
+--- a/config/FindVIGRANUMPY_DEPENDENCIES.cmake
++++ b/config/FindVIGRANUMPY_DEPENDENCIES.cmake
+@@ -115,6 +115,8 @@ IF(PYTHONINTERP_FOUND)
+ boost_python-${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}
+ # Mac with Python 3
+ boost_python${PYTHON_VERSION_MAJOR}
++ # conda-forge
++ boost_python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}
+ # default
+ boost_python)
+
diff --git a/media-libs/vigra/files/vigra-1.11.1-cmake-module-dir.patch b/media-libs/vigra/files/vigra-1.11.1-cmake-module-dir.patch
new file mode 100644
index 000000000000..cfc56b34722f
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.11.1-cmake-module-dir.patch
@@ -0,0 +1,17 @@
+CMake modules must be in cmake subdir.
+
+--- a/CMakeLists.txt 2017-05-19 17:01:08.000000000 +0200
++++ b/CMakeLists.txt 2019-11-26 23:50:40.660462479 +0100
+@@ -368,10 +368,10 @@
+
+ # export targets:
+ INSTALL(EXPORT vigra-targets
+- DESTINATION lib${LIB_SUFFIX}/vigra)
++ DESTINATION lib${LIB_SUFFIX}/cmake/vigra)
+ INSTALL(FILES ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfig.cmake
+ ${PROJECT_BINARY_DIR}/lib/vigra/CMake/VigraConfigVersion.cmake
+- DESTINATION lib${LIB_SUFFIX}/vigra)
++ DESTINATION lib${LIB_SUFFIX}/cmake/vigra)
+ EXPORT(TARGETS vigraimpex FILE vigra-targets.cmake)
+
+ ##################################################
diff --git a/media-libs/vigra/files/vigra-1.11.1-python3.7.patch b/media-libs/vigra/files/vigra-1.11.1-python3.7.patch
new file mode 100644
index 000000000000..2e6cd3469f8e
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.11.1-python3.7.patch
@@ -0,0 +1,30 @@
+From a6fa62663c6a6b752ed0707e95f643e25867a0f9 Mon Sep 17 00:00:00 2001
+From: John Kirkham <kirkhamj@janelia.hhmi.org>
+Date: Fri, 19 Oct 2018 11:32:42 -0400
+Subject: [PATCH] Receive `const char *` from `PyUnicode_AsUTF8`
+
+In Python 3.7, `PyUnicode_AsUTF8` was changed to return a `const char *`
+instead of a `char *`. This broke VIGRA as we were accepting a `char *`
+in this case instead. Fortunately we do not need it to be mutable for
+our use case. So just type the variable storing the result from
+`PyUnicode_AsUTF8` as a `const char *`. Should still work on older
+Python 3 versions that return `char *` as well.
+
+ref: https://bugs.python.org/issue28769
+---
+ vigranumpy/src/core/vigranumpycore.cxx | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/vigranumpy/src/core/vigranumpycore.cxx b/vigranumpy/src/core/vigranumpycore.cxx
+index ec38d3636..c81c6ae52 100644
+--- a/vigranumpy/src/core/vigranumpycore.cxx
++++ b/vigranumpy/src/core/vigranumpycore.cxx
+@@ -61,7 +61,7 @@ UInt32 pychecksum(python::str const & s)
+ return checksum(data, size);
+ #else
+ Py_ssize_t size = 0;
+- char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
++ const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
+ return checksum(data, size);
+ #endif
+ }
diff --git a/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch b/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch
new file mode 100644
index 000000000000..fc265763f6ad
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch
@@ -0,0 +1,27 @@
+Description: Replace sphinx.ext.pngmath by sphinx.ext.imgmath to build with sphinx 1.8
+Bug-Debian: https://bugs.debian.org/923467
+Author: Andreas Tille <tille@debian.org>
+Last-Update: Fri, 08 Mar 2019 18:38:02 +0100
+
+--- a/vigranumpy/docsrc/conf.py.cmake2.in
++++ b/vigranumpy/docsrc/conf.py.cmake2.in
+@@ -59,7 +59,7 @@ os.environ['PATH'] = os.pathsep.join([vi
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.imgmath']
+
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']
+--- a/vigranumpy/docsrc/conf.py.in
++++ b/vigranumpy/docsrc/conf.py.in
+@@ -58,7 +58,7 @@ os.environ['PATH'] = os.pathsep.join([vi
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.imgmath']
+
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']