summaryrefslogtreecommitdiff
path: root/media-libs/tse3/tse3-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
commit6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (patch)
tree401ffbc2ade49ce18f6182969ec5fb697a57ce48 /media-libs/tse3/tse3-0.3.1-r1.ebuild
parentd4bd6695641f6d2ec7ff8681913d304e995902f5 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'media-libs/tse3/tse3-0.3.1-r1.ebuild')
-rw-r--r--media-libs/tse3/tse3-0.3.1-r1.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/media-libs/tse3/tse3-0.3.1-r1.ebuild b/media-libs/tse3/tse3-0.3.1-r1.ebuild
index 08519f982de1..9c10927b83eb 100644
--- a/media-libs/tse3/tse3-0.3.1-r1.ebuild
+++ b/media-libs/tse3/tse3-0.3.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils flag-o-matic
+EAPI=6
+inherit autotools flag-o-matic
DESCRIPTION="TSE3 Sequencer library"
HOMEPAGE="http://TSE3.sourceforge.net"
@@ -17,17 +17,21 @@ IUSE="alsa oss"
RDEPEND="alsa? ( media-libs/alsa-lib )"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.7-size_t-64bit.patch"
+ "${FILESDIR}/${PN}-0.2.7-gcc4.patch"
+ "${FILESDIR}/${P}-parallelmake.patch"
+ "${FILESDIR}/${P}+gcc-4.3.patch"
+)
+
src_prepare() {
+ default
+ mv configure.in configure.ac || die "Moving configure.in -> .ac failed"
if use oss; then
- cp "${WORKDIR}"/awe_voice.h src/
- append-flags -DHAVE_AWE_VOICE_H
+ cp "${WORKDIR}"/awe_voice.h src/ || die "copy failed"
+ append-cppflags -DHAVE_AWE_VOICE_H
fi
- epatch "${FILESDIR}"/${PN}-0.2.7-size_t-64bit.patch \
- "${FILESDIR}"/${PN}-0.2.7-gcc4.patch \
- "${FILESDIR}"/${P}-parallelmake.patch \
- "${FILESDIR}"/${P}+gcc-4.3.patch
-
eautoreconf
}
@@ -44,7 +48,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS NEWS README THANKS TODO doc/History
- dohtml doc/*.{html,gif,png}
+ HTML_DOCS=( doc/*.{html,gif,png} )
+ default
+ dodoc doc/History
}