summaryrefslogtreecommitdiff
path: root/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild')
-rw-r--r--media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild b/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild
new file mode 100644
index 000000000000..d045fb6aff25
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6_pre12-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit multilib versionator
+
+DESCRIPTION="SpanDSP is a library of DSP functions for telephony"
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="doc fixed-point static-libs"
+
+RDEPEND="media-libs/tiff"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ dev-libs/libxslt )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+# TODO:
+# there are two tests options: tests and test-data
+# they need audiofile, fftw, libxml and probably more
+# configure script is auto-enabling some sse* options sometimes
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc) \
+ $(use_enable fixed-point) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog DueDiligence NEWS README || die "dodoc failed"
+
+ if ! use static-libs; then
+ # remove useless la file when not installing static lib
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "rm failed"
+ fi
+
+ if use doc; then
+ dohtml -r doc/{api/html/*,t38_manual} || die "dohtml failed"
+ fi
+}