summaryrefslogtreecommitdiff
path: root/media-libs/simage/simage-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-09 05:13:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-09 05:13:51 +0000
commitf6f5cf314dddfbfe0f8c848dc9e07436b032562c (patch)
tree4c18deb1fed0d1d81a1ac43f6f1c5de43a4533eb /media-libs/simage/simage-9999.ebuild
parent1a74c5436dbcb832445250e8f3ed0a00f6c2fcef (diff)
gentoo auto-resync : 09:12:2023 - 05:13:51
Diffstat (limited to 'media-libs/simage/simage-9999.ebuild')
-rw-r--r--media-libs/simage/simage-9999.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/media-libs/simage/simage-9999.ebuild b/media-libs/simage/simage-9999.ebuild
index ae5ce0a704a3..fcec6add0f0c 100644
--- a/media-libs/simage/simage-9999.ebuild
+++ b/media-libs/simage/simage-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake flag-o-matic
+inherit cmake
DESCRIPTION="Image and video texturing library"
HOMEPAGE="https://github.com/coin3d/simage/"
@@ -13,13 +13,14 @@ if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://github.com/coin3d/simage.git"
else
SRC_URI="https://github.com/coin3d/simage/releases/download/v${PV}/${P}-src.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
S="${WORKDIR}/${PN}"
fi
LICENSE="BSD-1"
SLOT="0"
-IUSE="gif jpeg png qt5 sndfile test tiff vorbis zlib"
+IUSE="gif jpeg png qt5 qt6 sndfile test tiff vorbis zlib"
+REQUIRED_USE="qt5? ( !qt6 )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -30,6 +31,9 @@ RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
)
+ qt6? (
+ dev-qt/qtbase:6[gui]
+ )
sndfile? (
media-libs/libsndfile
media-libs/flac:=
@@ -56,6 +60,12 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog NEWS README)
src_configure() {
+ local use_qt
+ if use qt5 || use qt6 ; then
+ use_qt=ON
+ else
+ use_qt=OFF
+ fi
local mycmakeargs=(
-DSIMAGE_BUILD_SHARED_LIBS=ON
-DSIMAGE_BUILD_EXAMPLES=OFF
@@ -65,8 +75,9 @@ src_configure() {
-DSIMAGE_USE_GDIPLUS=OFF # Windows
-DSIMAGE_USE_CGIMAGE=OFF # OS X only
-DSIMAGE_USE_QUICKTIME=OFF # OS X only
- -DSIMAGE_USE_QIMAGE=$(usex qt5)
+ -DSIMAGE_USE_QIMAGE=${use_qt}
-DSIMAGE_USE_QT5=$(usex qt5)
+ -DSIMAGE_USE_QT6=$(usex qt6)
-DSIMAGE_USE_CPACK=OFF
-DSIMAGE_USE_STATIC_LIBS=OFF
-DSIMAGE_LIBJASPER_SUPPORT=OFF