summaryrefslogtreecommitdiff
path: root/media-libs/shaderc/shaderc-2022.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 03:25:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 03:25:11 +0000
commit7db983f17e59dfa621d994bcbdbddc71a6e70a57 (patch)
treed3b613e9a32bbf84e338c3303136477226d57d04 /media-libs/shaderc/shaderc-2022.3.ebuild
parent4cf2f7cc6bbea59e8aec44b9508c759cf8bb4adf (diff)
gentoo auto-resync : 09:11:2022 - 03:25:11
Diffstat (limited to 'media-libs/shaderc/shaderc-2022.3.ebuild')
-rw-r--r--media-libs/shaderc/shaderc-2022.3.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/shaderc/shaderc-2022.3.ebuild b/media-libs/shaderc/shaderc-2022.3.ebuild
new file mode 100644
index 000000000000..5098336ac7d9
--- /dev/null
+++ b/media-libs/shaderc/shaderc-2022.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="Collection of tools, libraries and tests for shader compilation"
+HOMEPAGE="https://github.com/google/shaderc"
+EGIT_COMMIT="${PV}"
+SRC_URI="https://github.com/google/${PN}/archive/v${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-util/glslang-1.3.231:=[${MULTILIB_USEDEP}]
+ >=dev-util/spirv-tools-1.3.231[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/spirv-headers-1.3.231"
+
+BDEPEND="doc? ( dev-ruby/asciidoctor )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2020.4-fix-build.patch
+)
+
+# https://github.com/google/shaderc/issues/470
+RESTRICT=test
+
+src_prepare() {
+ cmake_comment_add_subdirectory examples
+
+ # Unbundle glslang, spirv-headers, spirv-tools
+ cmake_comment_add_subdirectory third_party
+ sed -i \
+ -e "s|\$<TARGET_FILE:spirv-dis>|${EPREFIX}/usr/bin/spirv-dis|" \
+ glslc/test/CMakeLists.txt || die
+
+ # Disable git versioning
+ sed -i -e '/build-version/d' glslc/CMakeLists.txt || die
+
+ # Manually create build-version.inc as we disabled git versioning
+ cat <<- EOF > glslc/src/build-version.inc || die
+ "${P}\n"
+ "$(best_version dev-util/spirv-tools)\n"
+ "$(best_version dev-util/glslang)\n"
+ EOF
+
+ cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DSHADERC_SKIP_TESTS="true"
+ -DSHADERC_ENABLE_WERROR_COMPILE="false"
+ )
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi && use doc; then
+ cmake_src_compile glslc_doc_README
+ fi
+ cmake_src_compile
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/glslc/README.html" )
+ fi
+ cmake_src_install
+}