summaryrefslogtreecommitdiff
path: root/media-libs/rubberband
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
commit71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /media-libs/rubberband
parent6612a728ea11526a849618ec515ad57131d64416 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/Manifest1
-rw-r--r--media-libs/rubberband/rubberband-1.8.1-r2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/rubberband/Manifest b/media-libs/rubberband/Manifest
index be3dce253787..3080d51106aa 100644
--- a/media-libs/rubberband/Manifest
+++ b/media-libs/rubberband/Manifest
@@ -1,3 +1,4 @@
DIST rubberband-1.8.1.tar.bz2 177501 BLAKE2B 57ca56abc7db2f2a25ff7c900daf24f32a892a1ef27099d34ab8ad290344ea8c5884cbace9206bfdf75262ee0c30bec8d736ae5398d5aaf92f73d0d5980e6932 SHA512 9721eaa36b80574f90b8ae5cfae388159a239e4257b8c85b9e55e7cf0dbbb9a996b857213a6a172a4ada5ff712e6936a16adbe08396e2ab1df3fd8d5a02a3620
EBUILD rubberband-1.8.1-r1.ebuild 1318 BLAKE2B ef83174727b0932afa5aadd90c0beaf29d099d01dc259cb57803e0c717e1b367ca962034964587fa5743474b057a0a93d32c343c54cdd42d0d637b6071eaad76 SHA512 da3e700e934bec7f7b05382c277c7d6226446052729363503631562b2eedc6a9e88e62595817344f25c153462806c20e77f8d7c2daa13386521192b3d56ba416
+EBUILD rubberband-1.8.1-r2.ebuild 1342 BLAKE2B f8d1f872e092a3d8f7a76ed7626dcab553f4e11e36d474c222ef58dbaeb2661fa6aafb9c491b30cea2bf01f7ef39c79eb755f92800cca555e18e9ed4d52bac50 SHA512 f80a3f0d07ecabb31e299ac044ed064e6df3df631faadc6ec9df85e9f27c86efd46ab5e6c391dc7be9ff6ef1e8d17d07386949c922d50fd36038338b408d690d
MISC metadata.xml 255 BLAKE2B 7a492321189530430d5c71d5598f8a99b548e020d8ace46bb200f1f18abb3a59c4d0dff84c8dc1f78297137c25684d42386d793b84a02e2363fab4d6dcedd4fa SHA512 9e74b875aa129f5b8108121402291772fde4ac18a157dc60f7b3e19c318ee54cd1be54e283a68bc61562f2dc3f5b338b161028d673ff7baa267192ff3b7e8dc8
diff --git a/media-libs/rubberband/rubberband-1.8.1-r2.ebuild b/media-libs/rubberband/rubberband-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..754ed4704a40
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.8.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib multilib-minimal
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="https://www.breakfastquay.com/rubberband/"
+SRC_URI="https://code.breakfastquay.com/attachments/download/34/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}]
+ media-libs/libsamplerate[${MULTILIB_USEDEP}]
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ sci-libs/fftw:3.0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ if ! use static-libs ; then
+ sed -e '/^all:/s/$(STATIC_TARGET)//' \
+ -e '/^\tcp $(STATIC_TARGET)/d' \
+ -i Makefile.in || die
+ fi
+ multilib_copy_sources
+}
+
+multilib_src_install() {
+ emake INSTALL_BINDIR="${ED}/usr/bin" \
+ INSTALL_INCDIR="${ED}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${ED}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${ED}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${ED}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${ED}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${ED}/usr/$(get_libdir)/pkgconfig" \
+ install
+}
+
+multilib_src_install_all() {
+ dodoc CHANGELOG README.txt
+}