summaryrefslogtreecommitdiff
path: root/media-libs/resid/resid-0.16_p2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/resid/resid-0.16_p2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/resid/resid-0.16_p2.ebuild')
-rw-r--r--media-libs/resid/resid-0.16_p2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/resid/resid-0.16_p2.ebuild b/media-libs/resid/resid-0.16_p2.ebuild
new file mode 100644
index 000000000000..a4a9b8ff6fd2
--- /dev/null
+++ b/media-libs/resid/resid-0.16_p2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit autotools versionator
+
+MY_MAJ=$(get_version_component_range 1-2)
+
+DESCRIPTION="C++ library to emulate the C64 SID chip"
+HOMEPAGE="http://sidplay2.sourceforge.net"
+SRC_URI="mirror://sourceforge/sidplay2/${P/_p/-p}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND=""
+
+S=${WORKDIR}/${PN}-${MY_MAJ}
+
+src_prepare() {
+ # This is required, otherwise the shared libraries get installed as
+ # libresid.0.0.0 instead of libresid.so.0.0.0.
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --enable-resid-install
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO VC_CC_SUPPORT.txt
+}