summaryrefslogtreecommitdiff
path: root/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild')
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
index 8c43fe24aa99..7f5d733485a6 100644
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake udev
DESCRIPTION="Raspberry Pi userspace tools and libraries"
HOMEPAGE="https://github.com/raspberrypi/userland"
@@ -64,8 +64,7 @@ src_install() {
doenvd "${FILESDIR}"/04${PN}
- insinto /lib/udev/rules.d
- doins "${FILESDIR}"/92-local-vchiq-permissions.rules
+ udev_dorules "${FILESDIR}/92-local-vchiq-permissions.rules"
# enable dynamic switching of the GL implementation
dodir /usr/lib/opengl
@@ -110,3 +109,7 @@ src_install() {
rm -rfv "${D}"/opt/vc/src || die
}
+
+pkg_postinst() {
+ udev_reload
+}