summaryrefslogtreecommitdiff
path: root/media-libs/pyliblo/pyliblo-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/pyliblo/pyliblo-0.10.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/pyliblo/pyliblo-0.10.0.ebuild')
-rw-r--r--media-libs/pyliblo/pyliblo-0.10.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-libs/pyliblo/pyliblo-0.10.0.ebuild b/media-libs/pyliblo/pyliblo-0.10.0.ebuild
new file mode 100644
index 000000000000..c888c9e2eba5
--- /dev/null
+++ b/media-libs/pyliblo/pyliblo-0.10.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for the liblo OSC library"
+HOMEPAGE="http://das.nasophon.de/pyliblo"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=media-libs/liblo-0.27
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"