summaryrefslogtreecommitdiff
path: root/media-libs/ptex/ptex-2.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /media-libs/ptex/ptex-2.3.2.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'media-libs/ptex/ptex-2.3.2.ebuild')
-rw-r--r--media-libs/ptex/ptex-2.3.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/ptex/ptex-2.3.2.ebuild b/media-libs/ptex/ptex-2.3.2.ebuild
new file mode 100644
index 000000000000..b9d0f650ba96
--- /dev/null
+++ b/media-libs/ptex/ptex-2.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
+HOMEPAGE="http://ptex.us/"
+SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+BDEPEND="app-doc/doxygen"
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-cxx11.patch" )
+
+src_prepare() {
+ # https://github.com/wdas/ptex/issues/41
+ cat <<-EOF > version || die
+ ${PV}
+ EOF
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
+ -DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}