summaryrefslogtreecommitdiff
path: root/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch')
-rw-r--r--media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch b/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
new file mode 100644
index 000000000000..fd79759f7ed4
--- /dev/null
+++ b/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
@@ -0,0 +1,39 @@
+diff -purN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2017-02-13 22:59:10.000000000 +0000
++++ b/CMakeLists.txt 2017-08-08 14:19:10.325817085 +0100
+@@ -8,11 +8,16 @@ include(FindThreads)
+
+ enable_testing()
+
+-# Detect the build type from the $FLAVOR environment variable
+-if ("$ENV{FLAVOR}" MATCHES "debug")
+- set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "type of build" FORCE)
+-else ()
+- set(CMAKE_BUILD_TYPE "Release" CACHE STRING "type of build" FORCE)
++if (NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
++ # Detect the build type from the $FLAVOR environment variable
++ # Default to optimized Release builds when unspecified.
++ if ("$ENV{FLAVOR}" MATCHES "debug")
++ set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "type of build" FORCE)
++ elseif ("$ENV{FLAVOR}" MATCHES "profile")
++ set(CMAKE_BUILD_TYPE "RelWithDebInfo" CACHE STRING "type of build" FORCE)
++ else ()
++ set(CMAKE_BUILD_TYPE "Release" CACHE STRING "type of build" FORCE)
++ endif ()
+ endif ()
+
+ if (NOT WIN32)
+diff -purN a/Makefile b/Makefile
+--- a/Makefile 2017-02-13 22:59:10.000000000 +0000
++++ b/Makefile 2017-08-08 14:19:16.939829578 +0100
+@@ -21,6 +21,10 @@ ifdef TOOLCHAIN
+ CMAKE_FLAGS += -DCMAKE_TOOLCHAIN_FILE=$(TOOLCHAIN)
+ endif
+
++ifdef BUILD_TYPE
++ CMAKE_FLAGS += -DCMAKE_BUILD_TYPE=$(BUILD_TYPE)
++endif
++
+ # make V=1 shortcut for VERBOSE=1
+ ifdef V
+ VERBOSE=1