summaryrefslogtreecommitdiff
path: root/media-libs/portsmf/portsmf-239.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
commit374561aeaff53ce5a2836af934749923b4ea3763 (patch)
tree66880cb44879bf28002f361a4c862814df616b8f /media-libs/portsmf/portsmf-239.ebuild
parentea0515fa73da4755b498bdb18bd7fd7a13e616cf (diff)
gentoo auto-resync : 20:01:2023 - 23:41:20
Diffstat (limited to 'media-libs/portsmf/portsmf-239.ebuild')
-rw-r--r--media-libs/portsmf/portsmf-239.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/portsmf/portsmf-239.ebuild b/media-libs/portsmf/portsmf-239.ebuild
new file mode 100644
index 000000000000..8b8578b7e613
--- /dev/null
+++ b/media-libs/portsmf/portsmf-239.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The Tenacity fork of PortSMF, a Standard MIDI File library"
+HOMEPAGE="https://github.com/tenacityteam/portsmf"
+SRC_URI="
+ https://github.com/tenacityteam/portsmf/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+"
+LICENSE="MIT"
+SLOT="0/1" # SOVERSION in CMakeLists.txt / SONAME suffix
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-239-revert-extern-to-static-change.patch
+ "${FILESDIR}/${PN}"-239-set-correct-cmake-project-ver.patch
+ "${FILESDIR}/${PN}"-239-set-correct-pkg-config-ver.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test on off)
+ ## This is "Build example applications" according to upstream
+ #-DBUILD_APPS=$(usex examples on off)
+ # The above requires a non-existent PortMidiConfig.cmake.
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Remove this function when bumping. Upstream HEAD has CTest.
+ cd "${BUILD_DIR}"/test || die
+ ./test </dev/null || die
+}