summaryrefslogtreecommitdiff
path: root/media-libs/plotutils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/plotutils/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/plotutils/files')
-rw-r--r--media-libs/plotutils/files/plotutils-2.5.1-rangecheck.patch14
-rw-r--r--media-libs/plotutils/files/plotutils-2.6-format-security.patch18
-rw-r--r--media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch31
-rw-r--r--media-libs/plotutils/files/plotutils-2.6-libxmi.patch114
-rw-r--r--media-libs/plotutils/files/plotutils-2.6-makefile.patch73
5 files changed, 250 insertions, 0 deletions
diff --git a/media-libs/plotutils/files/plotutils-2.5.1-rangecheck.patch b/media-libs/plotutils/files/plotutils-2.5.1-rangecheck.patch
new file mode 100644
index 000000000000..84b295913556
--- /dev/null
+++ b/media-libs/plotutils/files/plotutils-2.5.1-rangecheck.patch
@@ -0,0 +1,14 @@
+Source: Steve Tell (http://lists.gnu.org/archive/html/bug-gnu-utils/2003-12/msg00023.html)
+Upstream: Sent in 2003, not applied yet.
+Reason: Gentoo bug #47688
+--- plotutils-2.5.1.orig/graph/plotter.c 2008-09-26 23:48:15.000000000 +0200
++++ plotutils-2.5.1/graph/plotter.c 2008-11-08 13:10:14.000000000 +0100
+@@ -1011,7 +1011,7 @@
+ multigrapher->x_trans.output_min = 0.0;
+ multigrapher->x_trans.output_max = (double)PLOT_SIZE;
+ multigrapher->x_trans.output_range = multigrapher->x_trans.output_max - multigrapher->x_trans.output_min;
+- multigrapher->x_trans.output_min = 0.0;
++ multigrapher->y_trans.output_min = 0.0;
+ multigrapher->y_trans.output_max = (double)PLOT_SIZE;
+ multigrapher->y_trans.output_range = multigrapher->y_trans.output_max - multigrapher->y_trans.output_min;
+
diff --git a/media-libs/plotutils/files/plotutils-2.6-format-security.patch b/media-libs/plotutils/files/plotutils-2.6-format-security.patch
new file mode 100644
index 000000000000..c1cbecfc796b
--- /dev/null
+++ b/media-libs/plotutils/files/plotutils-2.6-format-security.patch
@@ -0,0 +1,18 @@
+Description: Fix build error with -Werror=format-security.
+Forwarded: https://lists.gnu.org/archive/html/bug-plotutils/2016-01/msg00000.html
+Author: Stanislav Ochotnicky <sochotnicky@redhat.com>
+Origin: http://pkgs.fedoraproject.org/cgit/plotutils.git
+
+diff --git a/pic2plot/gram.yy b/pic2plot/gram.yy
+index d11320b..1bcce46 100644
+--- a/pic2plot/gram.yy
++++ b/pic2plot/gram.yy
+@@ -1833,7 +1833,7 @@ do_sprintf(const char *form, const double *v, int nv)
+ {
+ one_format += *form++;
+ one_format += '\0';
+- sprintf(sprintf_buf, one_format.contents());
++ sprintf(sprintf_buf, "%s", one_format.contents());
+ }
+ else
+ {
diff --git a/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch b/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch
new file mode 100644
index 000000000000..b86d9f457421
--- /dev/null
+++ b/media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch
@@ -0,0 +1,31 @@
+fix building with libpng-1.5
+
+--- libplot/z_write.c
++++ libplot/z_write.c
+@@ -164,7 +164,7 @@
+ }
+
+ /* cleanup after libpng errors (error handler does a longjmp) */
+- if (setjmp (png_ptr->jmpbuf))
++ if (png_jmpbuf (png_ptr))
+ {
+ png_destroy_write_struct (&png_ptr, (png_info **)NULL);
+ return -1;
+@@ -444,7 +444,7 @@
+ #endif
+ }
+
+- longjmp (png_ptr->jmpbuf, 1);
++ longjmp (png_jmpbuf (png_ptr), 1);
+ }
+
+ static void
+@@ -515,7 +515,7 @@
+ #endif
+ }
+
+- longjmp (png_ptr->jmpbuf, 1);
++ longjmp (png_jmpbuf (png_ptr), 1);
+ }
+
+ static void
diff --git a/media-libs/plotutils/files/plotutils-2.6-libxmi.patch b/media-libs/plotutils/files/plotutils-2.6-libxmi.patch
new file mode 100644
index 000000000000..653869fc02d8
--- /dev/null
+++ b/media-libs/plotutils/files/plotutils-2.6-libxmi.patch
@@ -0,0 +1,114 @@
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ libplot/Makefile.am | 5 +++--
+ libplot/extern.h | 4 ++--
+ libplotter/Makefile.am | 6 ++++--
+ 5 files changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b506d17..09d3eda 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,7 +22,7 @@ endif
+ if NO_LIBXMI
+ ADD_LIBXMI =
+ else
+-ADD_LIBXMI = libxmi
++ADD_LIBXMI =
+ endif
+
+ SUBDIRS = lib spline double ode ode-examples libplot $(ADD_LIBXMI) plot tek2plot plotfont graph hersheydemo $(ADD_LIBPLOTTER) include info doc fonts test
+diff --git a/configure.ac b/configure.ac
+index 8fb7b64..4ea0fc4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -392,5 +392,5 @@ int main()
+ fi
+ fi
+
+-AC_CONFIG_FILES([Makefile double/Makefile graph/Makefile hersheydemo/Makefile pic2plot/Makefile pic2plot/doc/Makefile pic2plot/libgroff/Makefile pic2plot/include/Makefile info/Makefile lib/Makefile libplot/Makefile libplotter/Makefile libxmi/Makefile libxmi/info/Makefile plot/Makefile tek2plot/Makefile tek2plot/teksamples/Makefile plotfont/Makefile spline/Makefile ode/Makefile ode-examples/Makefile include/Makefile doc/Makefile fonts/Makefile fonts/bdf/Makefile fonts/pcf/Makefile fonts/pfb/Makefile test/Makefile])
++AC_CONFIG_FILES([Makefile double/Makefile graph/Makefile hersheydemo/Makefile pic2plot/Makefile pic2plot/doc/Makefile pic2plot/libgroff/Makefile pic2plot/include/Makefile info/Makefile lib/Makefile libplot/Makefile libplotter/Makefile plot/Makefile tek2plot/Makefile tek2plot/teksamples/Makefile plotfont/Makefile spline/Makefile ode/Makefile ode-examples/Makefile include/Makefile doc/Makefile fonts/Makefile fonts/bdf/Makefile fonts/pcf/Makefile fonts/pfb/Makefile test/Makefile])
+ AC_OUTPUT
+diff --git a/libplot/Makefile.am b/libplot/Makefile.am
+index 356cbef..a0cb2ff 100644
+--- a/libplot/Makefile.am
++++ b/libplot/Makefile.am
+@@ -8,7 +8,7 @@ libplot_la_LDFLAGS = -version-info 4:4:2
+
+ INCLUDES = $(X_CFLAGS) -I$(srcdir)/../include -DLIBPLOT
+
+-MISRC = mi_alloc.c mi_api.c mi_arc.c mi_canvas.c mi_fllarc.c mi_fllrct.c \
++_MISRC = mi_alloc.c mi_api.c mi_arc.c mi_canvas.c mi_fllarc.c mi_fllrct.c \
+ mi_fplycon.c mi_gc.c mi_ply.c mi_plycon.c mi_plygen.c mi_plypnt.c \
+ mi_plyutil.c mi_spans.c mi_widelin.c mi_zerarc.c mi_zerolin.c mi_version.c
+
+@@ -87,7 +87,7 @@ x_savestate.c x_text.c y_closepl.c y_defplot.c y_erase.c y_openpl.c
+
+ libplot_la_SOURCES = apinewc.c apioldc.c apioldcc.c $(ALLSRC)
+
+-MIHEADERS = xmi.h mi_api.h mi_arc.h mi_fllarc.h mi_fply.h mi_gc.h mi_line.h \
++_MIHEADERS = xmi.h mi_api.h mi_arc.h mi_fllarc.h mi_fply.h mi_gc.h mi_line.h \
+ mi_ply.h mi_scanfill.h mi_spans.h mi_widelin.h mi_zerarc.h
+
+ noinst_HEADERS = extern.h g_arc.h g_colorname.h g_control.h g_cntrlify.h \
+@@ -110,6 +110,7 @@ libplot_la_LIBADD = $(X_LIBS) $(X_TOOLKIT_LIBS) $(X_PRE_LIBS) $(X_BASIC_LIBS) $(
+ endif
+ endif
+
++libplot_la_LIBADD += -lxmi
+
+ ## execute the following command in ../libxmi to produce the commands
+ ## that follow
+diff --git a/libplot/extern.h b/libplot/extern.h
+index 39a6f8c..87a05f1 100644
+--- a/libplot/extern.h
++++ b/libplot/extern.h
+@@ -1262,7 +1262,7 @@ extern void _delete_color_name_cache (plColorNameCache *color_cache);
+ and a separate version of libxmi. */
+
+ /* libxmi API functions */
+-
++/*
+ #define miClearPaintedSet _pl_miClearPaintedSet
+ #define miCopyCanvas _pl_miCopyCanvas
+ #define miCopyGC _pl_miCopyGC
+@@ -1291,7 +1291,7 @@ extern void _delete_color_name_cache (plColorNameCache *color_cache);
+ #define miSetGCPixels _pl_miSetGCPixels
+ #define miSetPixelMerge2 _pl_miSetPixelMerge2
+ #define miSetPixelMerge3 _pl_miSetPixelMerge3
+-
++*/
+ /* an external libxmi symbol */
+ #define mi_libxmi_ver _pl_mi_libxmi_ver
+
+diff --git a/libplotter/Makefile.am b/libplotter/Makefile.am
+index 9b478d6..11466ad 100644
+--- a/libplotter/Makefile.am
++++ b/libplotter/Makefile.am
+@@ -6,7 +6,7 @@ libplotter_la_LDFLAGS = -version-info 4:4:2
+
+ INCLUDES = $(X_CFLAGS) -I$(srcdir)/../include -DLIBPLOT -DLIBPLOTTER
+
+-MISRC = mi_alloc.cc mi_api.cc mi_arc.cc mi_canvas.cc mi_fllarc.cc \
++_MISRC = mi_alloc.cc mi_api.cc mi_arc.cc mi_canvas.cc mi_fllarc.cc \
+ mi_fllrct.cc mi_fplycon.cc mi_gc.cc mi_ply.cc mi_plycon.cc mi_plygen.cc \
+ mi_plypnt.cc mi_plyutil.cc mi_spans.cc mi_widelin.cc mi_zerarc.cc \
+ mi_zerolin.cc mi_version.cc
+@@ -84,7 +84,7 @@ endif
+ endif
+
+
+-MIHEADERS = xmi.h mi_api.h mi_arc.h mi_fllarc.h mi_fply.h mi_gc.h mi_line.h \
++_MIHEADERS = xmi.h mi_api.h mi_arc.h mi_fllarc.h mi_fply.h mi_gc.h mi_line.h \
+ mi_ply.h mi_scanfill.h mi_spans.h mi_widelin.h mi_zerarc.h
+
+ ALLHEADERS = extern.h g_arc.h g_colorname.h g_control.h g_cntrlify.h \
+@@ -111,6 +111,8 @@ libplotter_la_LIBADD = $(X_LIBS) $(X_TOOLKIT_LIBS) $(X_PRE_LIBS) $(X_BASIC_LIBS)
+ endif
+ endif
+
++libplotter_la_LIBADD += -lxmi
++
+ ## execute the following command in ../libplot to produce the commands
+ ## that follow
+ ## (for i in ?_*.c; do echo "$i"c: "\$(top_srcdir)/libplot/$i"; echo " rm -f $i"c" ; if \$(LN_S) \$(top_srcdir)/libplot/$i $i"c" ; then true ; else cp -p \$(top_srcdir)/libplot/$i $i"c" ; fi"; echo; done)
diff --git a/media-libs/plotutils/files/plotutils-2.6-makefile.patch b/media-libs/plotutils/files/plotutils-2.6-makefile.patch
new file mode 100644
index 000000000000..a78801f3cf79
--- /dev/null
+++ b/media-libs/plotutils/files/plotutils-2.6-makefile.patch
@@ -0,0 +1,73 @@
+--- plotutils-2.6.orig/configure.ac 2009-07-29 20:14:09.000000000 -0700
++++ plotutils-2.6/configure.ac 2010-10-18 01:46:57.328444564 -0700
+@@ -65,6 +65,8 @@
+ # SCO OpenServer 5 (i.e. *-*-sco3.2v5*), "-belf" is added.
+ AC_PROG_LIBTOOL
+
++AC_PROG_CXX
++
+ # Determine extension (e.g. ".exe") on executables, if any.
+ AC_EXEEXT
+
+--- plotutils-2.6.orig/doc/Makefile.am 2009-07-30 08:49:46.000000000 -0700
++++ plotutils-2.6/doc/Makefile.am 2010-10-18 01:57:50.525852285 -0700
+@@ -3,11 +3,3 @@
+
+ # files with nonstandard names in this directory
+ EXTRA_DIST = colors.txt h-fonts.txt h-glyphs.txt hershey.bib kana.txt kanji.txt
+-
+-# remove documentation files installed by previous versions of the package,
+-# with obsolete names
+-
+-OBSOLETEDOC = hershey-demo.c hershey-fonts hershey-number hershey.doc h-fonts.doc h-glyphs.doc kana.doc kanji.doc demo-page h-demo.c
+-
+-install-data-hook:
+- -for f in $(OBSOLETEDOC) ; do rm -f $(datadir)/libplot/$$f; done
+--- plotutils-2.6.orig/graph/Makefile.am 2005-11-25 20:40:13.000000000 -0800
++++ plotutils-2.6/graph/Makefile.am 2010-10-18 01:23:07.194720342 -0700
+@@ -10,15 +10,5 @@
+
+ CLEANFILES = fontlist.c
+
+-# remove executables installed by previous versions of the package, and
+-# remove obsolete library versions too
+-
+-OBSOLETEBINS = graph-tek graph-hpgl graph-fig graph-ps graph-X
+-OBSOLETELIBS = libplottek.a libplothpgl.a libplotfig.a libplotps.a libplotX.a
+-
+-install-exec-hook:
+- -for f in $(OBSOLETEBINS) ; do rm -f $(bindir)/$$f; done
+- -for f in $(OBSOLETELIBS) ; do rm -f $(libdir)/$$f; done
+-
+ fontlist.c: $(top_srcdir)/lib/fontlist.c
+ @rm -f fontlist.c ; if $(LN_S) $(top_srcdir)/lib/fontlist.c fontlist.c ; then true ; else cp -p $(top_srcdir)/lib/fontlist.c fontlist.c ; fi
+--- plotutils-2.6.orig/plot/Makefile.am 2005-11-25 20:40:13.000000000 -0800
++++ plotutils-2.6/plot/Makefile.am 2010-10-18 01:23:37.714971379 -0700
+@@ -9,12 +9,5 @@
+
+ CLEANFILES = fontlist.c
+
+-# remove executables installed by previous versions of the package
+-
+-OBSOLETEBINS = plot2plot plot2tek plot2hpgl plot2fig plot2ps plot2X
+-
+-install-exec-hook:
+- -for f in $(OBSOLETEBINS) ; do rm -f $(bindir)/$$f; done
+-
+ fontlist.c: $(top_srcdir)/lib/fontlist.c
+ @rm -f fontlist.c ; if $(LN_S) $(top_srcdir)/lib/fontlist.c fontlist.c ; then true ; else cp -p $(top_srcdir)/lib/fontlist.c fontlist.c ; fi
+--- plotutils-2.6.orig/tek2plot/Makefile.am 2005-11-25 20:40:13.000000000 -0800
++++ plotutils-2.6/tek2plot/Makefile.am 2010-10-18 01:23:48.011056089 -0700
+@@ -12,12 +12,5 @@
+
+ SUBDIRS = teksamples
+
+-# remove executables installed by previous versions of the package
+-
+-OBSOLETEBINS = tek2tek tek2hpgl tek2fig tek2ps tek2X
+-
+-install-exec-hook:
+- -for f in $(OBSOLETEBINS) ; do rm -f $(bindir)/$$f; done
+-
+ fontlist.c: $(top_srcdir)/lib/fontlist.c
+ @rm -f fontlist.c ; if $(LN_S) $(top_srcdir)/lib/fontlist.c fontlist.c ; then true ; else cp -p $(top_srcdir)/lib/fontlist.c fontlist.c ; fi