summaryrefslogtreecommitdiff
path: root/media-libs/plib/plib-1.8.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /media-libs/plib/plib-1.8.5-r2.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'media-libs/plib/plib-1.8.5-r2.ebuild')
-rw-r--r--media-libs/plib/plib-1.8.5-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/plib/plib-1.8.5-r2.ebuild b/media-libs/plib/plib-1.8.5-r2.ebuild
new file mode 100644
index 000000000000..d3ca9fa91384
--- /dev/null
+++ b/media-libs/plib/plib-1.8.5-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit flag-o-matic autotools
+
+DESCRIPTION="multimedia library used by many games"
+HOMEPAGE="http://plib.sourceforge.net/"
+SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DEPEND="virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-X11-r1.patch
+ "${FILESDIR}"/${P}-CVE-2011-4620.patch
+ "${FILESDIR}"/${P}-CVE-2012-4552.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+
+ # Since plib only provides static libraries, force
+ # building as PIC or plib is useless to amd64/etc...
+ append-flags -fPIC
+}
+
+src_install() {
+ DOCS=( AUTHORS ChangeLog KNOWN_BUGS NOTICE README* TODO* )
+
+ default
+}