summaryrefslogtreecommitdiff
path: root/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild50
1 files changed, 7 insertions, 43 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
index b0e89138a56c..cd3c7c7b418c 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,20 +8,20 @@ MY_P=${MY_PN}-${PV}
if [[ ${PV} != *9999* ]]; then
SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
else
EGIT_REPO_URI=( "git://anongit.kde.org/${PN}" )
inherit git-r3
fi
-inherit cmake-utils multibuild
+inherit cmake-utils
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://phonon.kde.org/"
LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
SLOT="0"
-IUSE="alsa debug +network qt4"
+IUSE="alsa debug +network"
RDEPEND="
dev-libs/glib:2
@@ -33,52 +33,16 @@ RDEPEND="
dev-qt/qtx11extras:5
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
- >=media-libs/phonon-4.9.0[qt4?,qt5(+)]
+ >=media-libs/phonon-4.10.0
media-plugins/gst-plugins-meta:1.0[alsa?,ogg,vorbis]
virtual/opengl
network? ( media-plugins/gst-plugins-soup:1.0 )
- qt4? (
- >=dev-qt/qtcore-4.8.7-r2:4[glib]
- >=dev-qt/qtgui-4.8.7:4[glib]
- >=dev-qt/qtopengl-4.8.7:4
- !<dev-qt/qtwebkit-4.10.4:4[gstreamer]
- )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"
-pkg_setup() {
- if use qt4 && [[ $(gcc-major-version) -lt 5 ]] ; then
- ewarn "A GCC version older than 5 was detected. There may be trouble. See also Gentoo bug #595618"
- fi
-
- MULTIBUILD_VARIANTS=( $(usev qt4) qt5 )
-}
-
src_configure() {
- myconfigure() {
- local mycmakeargs=()
- if [[ ${MULTIBUILD_VARIANT} = qt4 ]]; then
- mycmakeargs+=( -DPHONON_BUILD_PHONON4QT5=OFF )
- fi
- if [[ ${MULTIBUILD_VARIANT} = qt5 ]]; then
- mycmakeargs+=( -DPHONON_BUILD_PHONON4QT5=ON )
- fi
- cmake-utils_src_configure
- }
-
- multibuild_foreach_variant myconfigure
-}
-
-src_compile() {
- multibuild_foreach_variant cmake-utils_src_compile
-}
-
-src_test() {
- multibuild_foreach_variant cmake-utils_src_test
-}
-
-src_install() {
- multibuild_foreach_variant cmake-utils_src_install
+ local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=ON )
+ cmake-utils_src_configure
}