summaryrefslogtreecommitdiff
path: root/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 03:31:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 03:31:11 +0000
commit3a9a4f8b478ff62e3c752e20305edb2c7d91959f (patch)
treeaf2b80e575254ddcdc57ea6b2ae02607bb0a7824 /media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild
parent7236d0a40beeff3f6f0fcede52d54dfb81880faa (diff)
gentoo auto-resync : 12:11:2022 - 03:31:11
Diffstat (limited to 'media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild
new file mode 100644
index 000000000000..3b0a28563e2d
--- /dev/null
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="phonon-backend-gstreamer"
+inherit ecm kde.org
+
+DESCRIPTION="GStreamer backend for the Phonon multimedia library"
+HOMEPAGE="https://community.kde.org/Phonon"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.xz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+IUSE="alsa debug +network"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ >=media-libs/phonon-4.10.60
+ media-plugins/gst-plugins-meta:1.0[alsa?,ogg,vorbis]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}
+ network? ( media-plugins/gst-plugins-soup:1.0 )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${P}-wayland.patch" ) # KDE-bug 445196