summaryrefslogtreecommitdiff
path: root/media-libs/phat/phat-0.4.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /media-libs/phat/phat-0.4.1-r2.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'media-libs/phat/phat-0.4.1-r2.ebuild')
-rw-r--r--media-libs/phat/phat-0.4.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/phat/phat-0.4.1-r2.ebuild b/media-libs/phat/phat-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..206b47e5d396
--- /dev/null
+++ b/media-libs/phat/phat-0.4.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
+HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
+SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="gnome-base/libgnomecanvas
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/gtk-doc
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+ "${FILESDIR}/${P}-libm-underlinking.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}