summaryrefslogtreecommitdiff
path: root/media-libs/partio/partio-1.1.0_p20170829.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/partio/partio-1.1.0_p20170829.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/partio/partio-1.1.0_p20170829.ebuild')
-rw-r--r--media-libs/partio/partio-1.1.0_p20170829.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/partio/partio-1.1.0_p20170829.ebuild b/media-libs/partio/partio-1.1.0_p20170829.ebuild
new file mode 100644
index 000000000000..bbba8e72a91c
--- /dev/null
+++ b/media-libs/partio/partio-1.1.0_p20170829.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils vcs-snapshot python-single-r1
+
+DESCRIPTION="A library for particle IO and manipulation"
+HOMEPAGE="http://www.disneyanimation.com/technology/partio.html"
+
+MY_GIT_COMMIT="2774ef3958da46d9f8a4230ebda9e04b1aa8f4e5"
+SRC_URI="https://github.com/wdas/${PN}/archive/${MY_GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ virtual/opengl
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )
+ dev-lang/swig:*
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.1.0-Rename-partconv.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e '/ADD_SUBDIRECTORY (src\/tests)/d' -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package doc Doxygen)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}