summaryrefslogtreecommitdiff
path: root/media-libs/opensubdiv/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/opensubdiv/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/opensubdiv/files')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch34
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch13
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch39
3 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch b/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
new file mode 100644
index 000000000000..2ebb638e3838
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
@@ -0,0 +1,34 @@
+diff -purN a/regression/CMakeLists.txt b/regression/CMakeLists.txt
+--- a/regression/CMakeLists.txt 2016-03-25 22:15:29.000000000 +0000
++++ b/regression/CMakeLists.txt 2016-06-05 14:09:19.202849569 +0100
+@@ -32,30 +32,4 @@ if (NOT NO_REGRESSION)
+
+ add_subdirectory(far_perf)
+
+- if(OPENGL_FOUND AND (GLEW_FOUND OR APPLE) AND GLFW_FOUND)
+- add_subdirectory(osd_regression)
+- else()
+- set(MISSING "")
+-
+- if (NOT OPENGL_FOUND)
+- list(APPEND MISSING OpenGL)
+- endif()
+-
+- if (NOT GLEW_FOUND)
+- list(APPEND MISSING glew)
+- endif()
+-
+- if (NOT GLFW_FOUND)
+- list(APPEND MISSING glfw)
+- endif()
+-
+- message(WARNING
+- "The following libraries could not be found : ${MISSING}. "
+- "The osd regression test will not be available. "
+- "If you have these libraries installed, please specify their "
+- "path to cmake (through the GLEW_LOCATION and GLFW_LOCATION "
+- "command line arguments or environment variables)."
+- )
+- endif()
+-
+ endif()
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch b/media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch
new file mode 100644
index 000000000000..2b5c71a37cb5
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.3.0-fix-quotes.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e02ce90c..6d4f5342 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -48,7 +48,7 @@ endif()
+ string(REGEX REPLACE "^v" "" OSD_SONAME ${OSD_SONAME})
+
+ add_definitions(
+- -DOPENSUBDIV_VERSION_STRING="${OSD_SONAME}"
++ -DOPENSUBDIV_VERSION_STRING=\\\"${OSD_SONAME}\\\"
+ )
+
+ #-------------------------------------------------------------------------------
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch b/media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch
new file mode 100644
index 000000000000..02027763f5ca
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.3.0-use-gnuinstalldirs.patch
@@ -0,0 +1,39 @@
+diff -purN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2017-07-25 21:58:09.000000000 +0100
++++ b/CMakeLists.txt 2017-08-15 14:51:36.771044414 +0100
+@@ -23,6 +23,7 @@
+ #
+
+ project(OpenSubdiv)
++include(GNUInstallDirs)
+
+ cmake_minimum_required(VERSION 2.8.6)
+
+@@ -63,15 +64,15 @@ if (NOT DEFINED CMAKE_INSTALL_PREFIX)
+ endif()
+
+ if (NOT DEFINED CMAKE_INCDIR_BASE)
+- set( CMAKE_INCDIR_BASE include/opensubdiv )
++ set( CMAKE_INCDIR_BASE ${CMAKE_INSTALL_INCLUDEDIR}/opensubdiv )
+ endif()
+
+ if (NOT DEFINED CMAKE_BINDIR_BASE)
+- set( CMAKE_BINDIR_BASE bin )
++ set( CMAKE_BINDIR_BASE ${CMAKE_INSTALL_BINDIR} )
+ endif()
+
+ if (NOT DEFINED CMAKE_LIBDIR_BASE)
+- set( CMAKE_LIBDIR_BASE lib )
++ set( CMAKE_LIBDIR_BASE ${CMAKE_INSTALL_LIBDIR} )
+ endif()
+
+ if (NOT DEFINED CMAKE_FRAMEWORKDIR_BASE)
+@@ -83,7 +84,7 @@ if (NOT DEFINED CMAKE_PLUGINDIR_BASE)
+ endif()
+
+ if (NOT DEFINED CMAKE_DOCDIR_BASE)
+- set( CMAKE_DOCDIR_BASE share/doc/opensubdiv )
++ set( CMAKE_DOCDIR_BASE ${CMAKE_INSTALL_DOCDIR} )
+ else()
+ if (IS_ABSOLUTE ${CMAKE_DOCDIR_BASE})
+ set( CMAKE_DOCDIR_BASE "${CMAKE_DOCDIR_BASE}" )