summaryrefslogtreecommitdiff
path: root/media-libs/openexr/openexr-2.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-libs/openexr/openexr-2.5.2-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-libs/openexr/openexr-2.5.2-r1.ebuild')
-rw-r--r--media-libs/openexr/openexr-2.5.2-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/openexr/openexr-2.5.2-r1.ebuild b/media-libs/openexr/openexr-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..63da2483c2cb
--- /dev/null
+++ b/media-libs/openexr/openexr-2.5.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+KEYWORDS="amd64 -arm arm64 hppa ~ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="cpu_flags_x86_avx doc examples static-libs utils test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/ilmbase:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${P}/OpenEXR"
+
+DOCS=( PATENTS README.md )
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/OpenEXRConfigInternal.h )
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" "${S}"/IlmImfTest/tmpDir.h || die "failed to set temp path for tests"
+
+ if use abi_x86_32 && use test; then
+ eapply "${FILESDIR}/${P}-0001-IlmImfTest-main.cpp-disable-tests.patch"
+ fi
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DINSTALL_OPENEXR_DOCS=$(usex doc)
+ -DINSTALL_OPENEXR_EXAMPLES=$(usex examples)
+ -DOPENEXR_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DOPENEXR_BUILD_UTILS=$(usex utils)
+ -DOPENEXR_INSTALL_PKG_CONFIG=ON # default
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ DOCS+=( doc/*.pdf )
+ fi
+ einstalldocs
+
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+}