summaryrefslogtreecommitdiff
path: root/media-libs/opencv/opencv-3.4.1-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /media-libs/opencv/opencv-3.4.1-r5.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'media-libs/opencv/opencv-3.4.1-r5.ebuild')
-rw-r--r--media-libs/opencv/opencv-3.4.1-r5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/opencv/opencv-3.4.1-r5.ebuild b/media-libs/opencv/opencv-3.4.1-r5.ebuild
index c8bf140695b9..cb9bc604ea9e 100644
--- a/media-libs/opencv/opencv-3.4.1-r5.ebuild
+++ b/media-libs/opencv/opencv-3.4.1-r5.ebuild
@@ -234,6 +234,7 @@ PATCHES=(
"${FILESDIR}/${P}-remove-git-autodetect.patch"
"${FILESDIR}/${P}-fix-build-with-va.patch" # bug https://bugs.gentoo.org/656576
"${FILESDIR}/${P}-popcnt.patch" # https://bugs.gentoo.org/633900
+ "${FILESDIR}/${P}-fix-on-x86.patch" # https://bugs.gentoo.org/682104
)
pkg_pretend() {
@@ -472,10 +473,9 @@ python_module_compile() {
# Set all python variables to load the correct Gentoo paths
mycmakeargs+=(
- # cheap trick: python_setup sets one of them as a symlink
- # to the correct interpreter, and the other to fail-wrapper
- -DPYTHON2_EXECUTABLE=$(type -P python2)
- -DPYTHON3_EXECUTABLE=$(type -P python3)
+ # python_setup alters PATH and sets this as wrapper
+ # to the correct interpreter we are building for
+ -DPYTHON_DEFAULT_EXECUTABLE=python
-DINSTALL_PYTHON_EXAMPLES=$(usex examples)
-DLIBPY_SUFFIX=64
)