summaryrefslogtreecommitdiff
path: root/media-libs/opencv/opencv-3.4.1-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /media-libs/opencv/opencv-3.4.1-r5.ebuild
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'media-libs/opencv/opencv-3.4.1-r5.ebuild')
-rw-r--r--media-libs/opencv/opencv-3.4.1-r5.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/opencv/opencv-3.4.1-r5.ebuild b/media-libs/opencv/opencv-3.4.1-r5.ebuild
index b03f24a84911..45086698e736 100644
--- a/media-libs/opencv/opencv-3.4.1-r5.ebuild
+++ b/media-libs/opencv/opencv-3.4.1-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,7 +23,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD"
SLOT="0/3.4.1" # subslot = libopencv* soname version
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux"
IUSE="contrib contrib_cvv contrib_dnn contrib_hdf contrib_sfm contrib_xfeatures2d cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_popcnt cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cuda debug dnn_samples +eigen examples ffmpeg gdal gflags glog gphoto2 gstreamer gtk ieee1394 jpeg jpeg2k lapack libav opencl openexr opengl openmp pch png +python qt5 tesseract testprograms threads tiff vaapi v4l vtk webp xine"
# OpenGL needs gtk or Qt installed to activate, otherwise build system
# will silently disable it Wwithout the user knowing, which defeats the
@@ -105,7 +105,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig[${MULTILIB_USEDEP}]
contrib_dnn? ( dev-libs/cereal )
eigen? ( dev-cpp/eigen:3 )
- java? ( >=virtual/jdk-1.6 )"
+ java? ( >=virtual/jdk-1.6 )
+ vaapi? ( x11-libs/libva )"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/opencv2/cvconfig.h
@@ -230,6 +231,8 @@ PATCHES=(
"${FILESDIR}/${P}-compilation-C-mode.patch" # https://bugs.gentoo.org/656530
"${FILESDIR}/${P}-python-lib-suffix-hack.patch"
"${FILESDIR}/${P}-cuda-add-relaxed-constexpr.patch"
+ "${FILESDIR}/${P}-remove-git-autodetect.patch"
+ "${FILESDIR}/${P}-fix-build-with-va.patch" # bug https://bugs.gentoo.org/656576
)
pkg_pretend() {